1 (edited by christophe.lemaitre 2019-03-29 12:23:43)

Topic: Perte de schémas

Bonjour, j'ai un soucis de perte de schémas, a l'ouverture le message :

"il semblerait que le fichier ************.qet ne sois pas un fichier projet Qelectrotech. il ne peut donc pas etre ouvert"

Avez vosu rencontrer ce pproblème? mais surtout y a t-il une solution? 
J'ai les larmes aux yeux je transmet le schémas ci dessous.. 
Merci

Post's attachments

Attachment icon MASTER MICHELIN.rar 5.84 kb, 61 downloads since 2019-03-29 

2 (edited by galexis 2019-03-29 15:00:20)

Re: Perte de schémas

J'ai aussi eu le soucis avec la version readytouse v0.7SVN5778 qui m'a été envoyé par mail par un collègue qui l'a dessiné sur son poste. En prenant le fichier sur le réseau en directe, plus de problème. J'avais mis cela sur le compte du voyage par mail ....
QET crashait à l'ouverture de ce fichier "corrompue".

3

Re: Perte de schémas

Bonjour,

que c'est -il passé ?
Le fichier que tu as mis en ligne ne contient que des caractères NUL, donc est irrécupérable.

monospace ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^

4

Re: Perte de schémas

Bah rien de spécial, j'ai voulus l'ouvrir ce matin pour faire des modifs, et il m'as marqué que ca n'était pas un fichier qelec nomicons/unsure

5

Re: Perte de schémas

Étrange, t'as déjà eu des fichiers corrompus sur cette machine?

6

Re: Perte de schémas

Oui même erreur j'avais du retaper tout le schémas... J'ai le Pdf on peux le faire en .qet ? Je pense pas mais je demande dans le plus grand désespoir, mon schemas fait une centaine de folio... :'(

7

Re: Perte de schémas

Non, je ne pense pas qu'on puisse re convertir du PDF en .qet, par contre je n'aurai pas trop confiance dans ta machine, win10?
Pour les gros projets tu ne fais pas des backups à coté?
Ou activer les backups automatiques sur la 0.7.

8

Re: Perte de schémas

Bon, ça se termine bien pour Christophe, il a pu récupérer son projet disparu. nomicons/smile


Je ne sais ni comment ni pourquoi, mais ce matin en voulant ouvrir un
autre projet, Qelec m'as ouvert le projet michelin en backup?!?!?!! ...
j'en ai pleuré de joie  ! 

9

Re: Perte de schémas

Good day.
I also have a problem like you. I already talked about this problem. I think this is a serious problem.The only thing that helped me, I make copies. The project is completely removed, without the possibility of recovery.

Post's attachments

error-delete.png, 76.21 kb, 1149 x 261
error-delete.png 76.21 kb, 66 downloads since 2019-04-23 

10

Re: Perte de schémas

And about the discovery in another project, this could be if you had another one open while working in that project. So I restored my project. But this is only if several projects were opened. If only this project is open, it is deleted without recovery. I now make copies.

11

Re: Perte de schémas

To Christophe and Modicon :
What your OS, CPU, and RAM ?

12

Re: Perte de schémas

scorpio810 wrote:

To Christophe and Modicon :
What your OS, CPU, and RAM ?

ce matin de nouveau.... Je t'envoie l'erreur capturé et pour répondre a ta question précédente les captures de ma config

Post's attachments

Capture BUG.PNG, 65.17 kb, 1102 x 805
Capture BUG.PNG 65.17 kb, 9 downloads since 2019-09-30 

13

Re: Perte de schémas

config PC

Post's attachments

Capture PC1.PNG, 51.84 kb, 1116 x 884
Capture PC1.PNG 51.84 kb, 2 downloads since 2019-09-30 

14

Re: Perte de schémas

Config PC2

Post's attachments

Capture PC2.PNG, 26.15 kb, 1144 x 491
Capture PC2.PNG 26.15 kb, 3 downloads since 2019-09-30 

15 (edited by christophe.lemaitre 2019-09-30 08:55:33)

Re: Perte de schémas

ci joint le schémas corrompue

Post's attachments

Attachment icon MASTER-UO22-KUR-ELE-SCH-001-rev0.rar 100 b, 16 downloads since 2019-09-30 

16

Re: Perte de schémas

Bonjour Christophe,

malheureusement ton fichier une fois extrait est vide.

Rien dans C:\Users\chris\AppData\Local\stalefiles\QElectroTech ?

Ce qui est étrange d’après vos retours c'est que ce problème ne concerne que la plateforme MS Windows....

17 (edited by christophe.lemaitre 2019-09-30 11:50:57)

Re: Perte de schémas

Il y a ça

Post's attachments

Capture sco.PNG, 22.6 kb, 1305 x 460
Capture sco.PNG 22.6 kb, 4 downloads since 2019-09-30 

18

Re: Perte de schémas

Size 0 bytes nomicons/sad

Post's attachments

Screenshot from 2019-09-30 16-44-18.png, 34.11 kb, 965 x 465
Screenshot from 2019-09-30 16-44-18.png 34.11 kb, 4 downloads since 2019-09-30 

19 (edited by Joshua 2019-09-30 19:47:24)

Re: Perte de schémas

Hum j'ai vraiment du mal avec ce bug nomicons/sad 
Par contre le truc qui est vraiment étrange c'est que ton fichier soit vide, mais aussi le fichier de backup qui lui aussi fait 0 Ko car dans le code ceux sont deux fonctions différente (la sauvegarde et le backup) mais qui visiblement donne le même résultat.
Ça pourrais donc laisser croire que le problème vient d'avant l'écriture dans le fichier, mais d'un autre coté ça semble toucher que windows et qui du coup la seul différence avec les autres OS c'est l'écriture dans le fichier (dont je n'ai pas la main dessus).
Je pensais avoir réglé le problème en utilisant QSaveFile mais non.....
Bref tant de mots pour dire qu'au final je n'ai pas de solution mais je planche dessus.

20

Re: Perte de schémas

@Christophe : tu devrais faire des backups de tes projets importants, sur de gros projets j'ouvre toujours l'ancienne version et je fais de suite enregistrer sous en modifiant par la date du jour au format US, j'ouvre mon projet-19-09-28.qet et je faisais enregistrer sous projet-19-10-2.qet ça me permettrai d'avoir un historique et quand QET était instable sur les versions 0.4, 0.5, ne perdre que quelques heures ou au max un jour de travail, et même de pouvoir revenir en arrière suite à une bourde ou autre changements dans le projet.

C'est une méthode de bon sens qui s'applique quelque soit le logiciel surtout quand le travail demande de longs mois..

21

Re: Perte de schémas

@Christophe :
j'enfonce aussi le clou ! Quand on bosse pendant plusieurs jours, semaines, mois, voire années sur un projet, il faut faire des sauvegardes incrémentielles soi-même. Au moins une par jour quand on travail tous les jours sur ce même projet.

Peu importe l'OS et le logiciel, il s'agit essentiellement d'hygiène de travail.

22

Re: Perte de schémas

Il semble qu'il ai un problème de PATH non réglé sur cette plateforme, la bdd de cache permettant d’accélérer le chargement de la collection au lancement du logiciel, ne contient que la structure.
La bdd "elements_cache.sqlite" fait environ 27.6 MIo  sur ma Debian dont le chargement est ultra rapide, et 20 KIo sur Win 10...

23

Re: Perte de schémas

Effectivement même chose sur un pc Windows, je sais ce qu'il me reste à faire nomicons/wink