1

Topic: install the DXF converter 2017-Jul-18

Hello,
I would like to install the DXF converter 2017-Jul-18, but I can not start from QElectrotech. I work with version V 0.60-RC3 + svn5127 and XUBUNTU 16.04. In a Virtual Box I have XUBUNTU 17.10 and the version 0.70.r5129 and there it works. Does the DXF Converter 2017-Jul-18 only work with a later version?

Best regards

Stebo

2

Re: install the DXF converter 2017-Jul-18

@ Calypso:
did you make the file executable?

chmod +x DXFtoQET

3 (edited by Calypso 2017-12-03 13:09:27)

Re: install the DXF converter 2017-Jul-18

Hello Nuri,
I entered chmod +x /home/stebo/.qet/DXFtoQET in XUBUNTU 17.10 in a terminal and I was able to start the DXF converter from QElectrotech. But if I do it the same way with XUBUNTU 16.04 it will not work.

Best regards

Stebo

4 (edited by Nuri 2017-12-03 15:12:11)

Re: install the DXF converter 2017-Jul-18

Hi Stebo,

I'm on ubuntu 16.04 (Unity) and I have downloaded the last DXFtoQET from 2017-Jul-18.
I have made the file executable and then, I have tried to run it from the GUI -> nothing happened.
Then I have tried to run it from the Terminal and I get the following output:

nuri@nurikiste:~/.qet$ ./DXFtoQET
./DXFtoQET: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by ./DXFtoQET)
./DXFtoQET: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by ./DXFtoQET)
./DXFtoQET: /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5: version `Qt_5' not found (required by ./DXFtoQET)
./DXFtoQET: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by ./DXFtoQET)

It seams that the Qt libraries are to old on 16.04.

Try to run an older version of DXFtoQET on 16.04.
On my system, I run the version from 2017-02-22.

5

Re: install the DXF converter 2017-Jul-18

Hello Nuri,
I get no error messages in the terminal. I have tried all versions, only the version linux_x86-64_qt5.5.1 / 2016-Mar-26 I can start from QElectrotch. Funny thing is that I can start the version linux_x86-64_qt5.5.1 / 2016-Mar-26 without QElectrotech.

Best regards

Stebo

6

Re: install the DXF converter 2017-Jul-18

Hi Calypso,

you could also download latest dxftoelmt branch and compil it with your Qt 5 version.

svn checkout svn://svn.tuxfamily.org/svnroot/qet/qet/branches/DXFtoQET3_DB DXFtoQET3_DB
cd DXFtoQET3_DB/
qmake-qt5   # or qmake
make -j$(nproc)
chmod +x ./DXFtoQET
./DXFtoQET


mv ./DXFtoQET ~/.qet/

Btw, or a specific commit (see web svn) for changelog : https://svnweb.tuxfamily.org/log.php?re … dir=1&


svn export svn://svn.tuxfamily.org/svnroot/qet/qet/branches/DXFtoQET3_DB --revision 4988 DXFtoQET3_DB_rev-4988

7

Re: install the DXF converter 2017-Jul-18

Hello scorpio810,
So I downloaded the version DXF converter 2017-Jul-18 and subversion installed. After I saved the file in the directory / home / stebo /. After executing your statement, the file is moved to the .qtec folder and a new DXFtoQTEC3_DB folder is located in the / home / stebo / directory.
But I can not start the DXFtoQET converter. Did I forgot something?

Best regards

Stebo

8

Re: install the DXF converter 2017-Jul-18

Hi Caplyso,

I think you need to install qt5-qmake, libqt5core5a, qtbase5-dev, libqt5svg5-dev, libqt5gui5, libqt5sql5-sqlite, etc

laurent@debian:~/test/DXFtoQET3_DB$ objdump -p /home/laurent/test/DXFtoQET3_DB/./DXFtoQET | grep NEEDED                      
 NEEDED               libQt5Widgets.so.5
 NEEDED               libQt5Gui.so.5
 NEEDED               libQt5Sql.so.5
 NEEDED               libQt5Core.so.5
 NEEDED               libGL.so.1
 NEEDED               libpthread.so.0
 NEEDED               libstdc++.so.6
 NEEDED               libm.so.6
 NEEDED               libgcc_s.so.1
 NEEDED               libc.so.6





9

Re: install the DXF converter 2017-Jul-18

Hello scorpio810,
The folder DXFtoQET3_DB is generated by me but with me is not so much in it as with you. I think I missed something or did something wrong. I will once again watch your video to understand your approach.

Best regards

Stebo

10

Re: install the DXF converter 2017-Jul-18

You need to compile program DXFtoQET3_DB with your Qt libs installed.

11

Re: install the DXF converter 2017-Jul-18

OK,
have qt5-qmake installed version 5.5.1 for XUBUNTU 16.04 is the latest.
XUBUNTU 17.10 uses version 5.9.1 I think it depends on it. I will then install XUBUNTU 17.10 on my main system.

Best regards

Stebo

12

Re: install the DXF converter 2017-Jul-18

Don't upgrade your XUBUNTU 16.04 to 17.10, just install needed Qt 5.5.1 libs for compile and build yourself DXFtoQET3_DB.
The goal is to build plugin with your Qt version installed in your distrib.

Best regards,
Laurent

13 (edited by Calypso 2017-12-07 15:17:37)

Re: install the DXF converter 2017-Jul-18

Hello scorpio810,
I'm not looking right through, they are installed (qt5-qmake, libqt5core5a, qtbase5-dev, libqt5svg5-dev, libqt5gui5, libqt5sql5-sqlite) which ones do I need? These can not be installed (libQt5Widgets.so.5, libQt5Gui.so.5, libQt5Sql.so.5, libQt5Core.so.5, libGL.so.1, libpthread.so.0, libstdc ++. So.6, libm. so.6, libgcc_s.so.1, libc.so.6), they do not exist with me.


Best regards


EDIT: I have compared the qt libs of XUBUNTU 16.04 and XUBUNTU17.10 are the same registered difference is the version 5.5.1 and 5.9.1

Stebo

14

Re: install the DXF converter 2017-Jul-18

These can not be installed (libQt5Widgets.so.5, libQt5Gui.so.5, libQt5Sql.so.5, libQt5Core.so.5, libGL.so.1, libpthread.so.0, libstdc ++. So.6, libm. so.6, libgcc_s.so.1, libc.so.6)

libQt5Core.so.5 etc is libs name when you install libqt5core5a package.


open your DXFtoQET3_DB in a terminal

qmake-qt5   # or qmake
make

15 (edited by Calypso 2017-12-07 19:22:54)

Re: install the DXF converter 2017-Jul-18

So qmake-qt5 is installed but when I enter your commands in the terminal following statement:
The command qmake-qt5 was not found, you might have said:
 qmake-qt4 command from the qt4-qmake package (main)
qmake-qt5: Command not found.
stebo @ stebo: ~ $ make


Best regards
Stebo

16

Re: install the DXF converter 2017-Jul-18

sudo apt install qt5-qmake

Obviously, the name of the package had been changed nomicons/sideways

17 (edited by Calypso 2017-12-07 19:22:41)

Re: install the DXF converter 2017-Jul-18

the package is already installed. I do not look through enymore nomicons/cwy

stebo @ stebo: ~ $ sudo apt install qt5-qmake
Package lists are read ... Done
Dependency tree is set up.
Status information is read .... Done
"Qt5-qmake" is already the latest version (5.5.1 + dfsg-16ubuntu7.5).
0 updated, 0 reinstalled, 0 removed and 0 not updated.
stebo @ stebo: ~ $

Best regards

Stebo

18

Re: install the DXF converter 2017-Jul-18

Try 
/usr/lib/x86_64-linux-gnu/qt5/bin/qmake  or qt5-qmake
make

19 (edited by Calypso 2017-12-08 11:20:38)

Re: install the DXF converter 2017-Jul-18

Hello scorpio810,
what do you mean the file is there.

Best regards
Stebo

Post's attachments

2017-12-08 10:14:21.png, 9.38 kb, 449 x 203
2017-12-08 10:14:21.png 9.38 kb, 231 downloads since 2017-12-08 

20

Re: install the DXF converter 2017-Jul-18

Hello Caplyso,

have you tried to compil it now?


Download source files :

svn checkout svn://svn.tuxfamily.org/svnroot/qet/qet/branches/DXFtoQET3_DB DXFtoQET3_DB

Go to directory :

cd DXFtoQET3_DB/

Compilation

/usr/lib/x86_64-linux-gnu/qt5/bin/qmake
make -j$(nproc)

Make it executable

chmod +x ./DXFtoQET

Test if run 

./DXFtoQET

Now move or copy to QET user folder

mv ./DXFtoQET ~/.qet/

Now, the DXF converter can be started from the QET editor menu.

21

Re: install the DXF converter 2017-Jul-18

Hello scorpio810,
so I have:
 
Download source files:

svn checkout svn: //svn.tuxfamily.org/svnroot/qet/qet/branches/DXFtoQET3_DB DXFtoQET3_DB

OK then:

Go to directory:

cd DXFtoQET3_DB /

OK then:

compilation

/ Usr / lib / x86_64-linux-gnu / QT5 / bin / qmake
make -j $ (nproc)

when I come in heaps of error messages and warnings.

I do not know, but at some point a file called Makefile has been created in the folder DXFtoQET3_DB.

I will try again but it seems as if there is always demand for qt4 although it is not installed.

Best regards

Stebo

22

Re: install the DXF converter 2017-Jul-18

It 's only Qt 5 version DXFtoQET3_DB
Yes we can see a lot of warnings, but compil fail or finish?
Paste the end of compilation, if you make it executable you can launch program?

23 (edited by Calypso 2017-12-09 18:08:54)

Re: install the DXF converter 2017-Jul-18

Hello scorpio810,
so I have uninstalled everything from qt5 (qt5-qmake, libqt5core5a and others). Then I have all reinstalled, then I've done your steps again. After doing the path / usr / lib / x86_64-linux-gnu / QT5 / bin / qmake make -j $ (nproc), the terminal continued to run and the DXFtoQET Converter was installed. Why it did not work yesterday when entering the path I can not say exactly.

Best regards

Stebo

24

Re: install the DXF converter 2017-Jul-18

Hello Calypso,

nice, you have now DXF converter run with your Qt 5.5.1 libs.

Best regards,
Laurent

25

Re: install the DXF converter 2017-Jul-18

Nuri wrote:


@ Calypso:
did you make the file executable?

chmod +x DXFtoQET

Or in one command to get and launch it :

x=DXFtoQET; wget https://download.tuxfamily.org/qet/builds/dxf_to_elmt/linux/2017-07-18/${x}; chmod +x ${x}; ./${x}

cd ~/.qet/ 
laurent@debian:~/.qet$ x=DXFtoQET; wget https://download.tuxfamily.org/qet/builds/dxf_to_elmt/linux/2017-07-18/${x}; chmod +x ${x}; ./${x}
--2019-06-23 12:16:35--  https://download.tuxfamily.org/qet/builds/dxf_to_elmt/linux/2017-07-18/DXFtoQET
Résolution de download.tuxfamily.org (download.tuxfamily.org)… 2a01:e0d:1:3:58bf:fa12:0:1, 2a01:e0d:1:4:58bf:faab:0:1, 88.191.250.18, ...
Connexion à download.tuxfamily.org (download.tuxfamily.org)|2a01:e0d:1:3:58bf:fa12:0:1|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 750832 (733K) [application/octet-stream]
Sauvegarde en : « DXFtoQET »
 
DXFtoQET                                                                                     100%[==========================================================================================================================================================================================================================================================>] 733,23K  1,46MB/s    ds 0,5s    
 
2019-06-23 12:16:35 (1,46 MB/s) — « DXFtoQET » sauvegardé [750832/750832]
 
[12:16:39] laurent@debian:~/.qet$

Enjoy !