1

Topic: Appimage and/or flatpack to replace some distro specifik packagings?

I have seen more and more programs getting packged in a way that the same file can be downloaded and run on most major distributions.  I was thinking if QET was available too like that it would ease adoption, and maybe less total work to reach more distros and wider audience?

It also makes it easy to have more than one version "installed" at the same time.
The frequent releases may not be needed in any other format, i think. (at least for Linux)

Example technical programs: For my 3dprinter i run FreeCAD and Slic3er as appimage, and there is KiCad from flatpack for circuit boards.  They are all packaged in my distro, but the flatpack & appimage from authors is updated to new versions quicker, and i can easily have both a stable reliable and a development version for new functions installed.

https://appimage.org/   https://www.flatpak.org/
They also have places they list available programs, so you could get marketing that way too nomicons/wink

My personal preference is Appimage as it do not need root privilegies to install appimages, and it is possible to run applications jailed easily if you are concerned about that.


BTW i tried to search forum first on this topic, but the search function here above only keep showing two instances of "Loading..." with Google Custom search logo between...

2

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Hi Morganol,

isn't a bad idea, but we are too few to study these new packaging ..
you could see old topic about ubuntu snap and what I thinking ...

https://qelectrotech.org/forum/viewtopi … 4685#p4685

Well, ubuntu snap, Appimage, flatpack ... which one to choose ... and that does not require months of work ...

Packaging application is not very  a easy work and need a lot of time and more builds, compilation and tests..
you can see here the efforts that had to be made for making good packages for Debian, stable and unstable, all Ubuntu distribs, Windows XP 32, 64, Win10 installer and ReadyToUse, cross-compil, macOS dmg, etc.

https://qelectrotech.org/wiki_new/doc/p … ing_script
https://qelectrotech.org/wiki_new/doc/macosx
https://svnweb.tuxfamily.org/filedetail … Info.plist
https://svnweb.tuxfamily.org/filedetail … tDeploy.sh
https://svnweb.tuxfamily.org/filedetail … FQET64.nsi





etc, etc.. sorry but I 'm only one to make all packages for different OS and OS versions.
If you find a good developer howto (and easy of course)? nomicons/smile

BTW, I have idea to buy a 32" 4K screen to trying debug QET HiDPI in different OS, and different D.E, but I think is a bad idea not a time wasting but eat my little of free time ..
I prefer upgrading to a 16/32 CPU plateform for building all packages and perhaps appimage flatpack ..but this cost a lot (only have 350€ now)  and need approximately again ~ 1500€ to buy a TR 1950X CPU, new motherboard, 64 GB RAM, new ATX PSU.

3

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Yes i know you are working hard on this on your free time. A big thank you for that nomicons/smile
I was thinking to cover more distros with *less* work (except initial learning) for both your protein based and silicon based CPU:s nomicons/wink

Of the alternatives, it seem to me Appimage gives the best coverage in return of work, and is easy to use for users
To me it seem easy to package, but this is not "my cup of tea" and i dont know how many obstacles there may be:

Some cut-paste:

"There are different ways to generate an AppImage of your application:
...
3. Run linuxdeployqt on your Qt application"
...

"linuxdeployqt takes an application as input and makes it self-contained by copying in the resources that the application uses (like libraries, graphics, and plugins) into a bundle. The resulting bundle can be distributed as an AppDir or as an AppImage"
...
When used on Qt-based applications, it can bundle a specific minimal subset of Qt required to run the application."

---

BTW, QET 0.6 final is in Mageia development version "Cauldron" and will be released in current Mageia 6 normal updates but is waiting for a large Qt-Plasma5-etc-depending mess update currently being tested. - Appimage could get past such delays nomicons/wink

---

Further reading:
https://github.com/AppImage/AppImageKit/wiki
https://github.com/AppImage/AppImageKit … /README.md
https://github.com/probonopd/linuxdeployqt  - also see "known issues"

---

Did i have money i would donate for your highDPI screen.  Once I did (accidentally, in xorg.conf) set up a high X/Y resolution desktop, and panned my physical screen across it (when mouse touched edge).  There may be better methods nowadays in your distro of choice. I dont know if that may be an idea to simulate highDPI.

4

Re: Appimage and/or flatpack to replace some distro specifik packagings?

I have  this 27 " FHD monitor : https://www.philips.com.au/c-p/273V5LHA … ntrol-lite
Not the best, but for my use : programming, surfing, and QET drawing, I think is not bad.

When I saw to equivalent without scale playing , I do horrified by prices, and don't know if my plasma D.E run well with this hight resolutions.

https://shop.hardware.fr/peripheriques/ … 6220,6219/

https://shop.hardware.fr/peripheriques/ … 6220,6219/

What do you suggest?

5

Re: Appimage and/or flatpack to replace some distro specifik packagings?

I bought my monitor used years ago. Was impressive then with 30" 2560x1600, displayport.  I also still use the machine i built eleven years ago, but newer disk and SSD.  The only problem with the monitor is that it use much power, so it actually is unpleasant to sit long time before it, especially in summer.  I also guess that a larger screen and longer distance to it is better for the eyes, if we have possibility to arrange it at distance.

If i had the budget to upgrade i would buy a TV - less pricey than a monitor, and i do not play game so need not very quick response.  Here is one alternative for about 400 EUR: https://www.elgiganten.se/product/ljud- … -43pus6162

6

Re: Appimage and/or flatpack to replace some distro specifik packagings?

BTW, QET 0.6 final is in Mageia development version "Cauldron" and will be released in current Mageia 6 normal updates but is waiting for a large Qt-Plasma5-etc-depending mess update currently being tested. - Appimage could get past such delays 

Nice, thanks nomicons/smile

My 27" monitor is very cold and use only 20 W power and 0.5 W in stand-by, it at 70 centimeter of my old eyes, uhuu.
Be careful TV isn't a good PC monitor and if you work like me at minimal distance you can destroy your eyes.. nomicons/cwy

New screen is a little luxurious I think, but it will have to go through .. there many users now have this type of screen.
Fortunately Gabberworld helping a lot for MS Windows HiDPI support.

I'm afraid to regret spending your donations in a monitor and to be very disappointed afterwards, I prefer to keep your donates to later update the nightly QET packages builder to a Amd threadripper 16/32 cores, but RAM prices is very mad now... nomicons/dizzy

7

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Yes, as I said "Did i have money", i dont have more then needed to get around, since i "went into the wall".

8

Re: Appimage and/or flatpack to replace some distro specifik packagings?

If you could try it..

QElectroTech V 0.70-dev+svn5428
Compilation : GCC 5.4.0 20160609 - built with Qt 5.5.1 - run with Qt 5.5.1 using 16 thread(s)

9 (edited by Morganol 2018-07-09 23:32:42)

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Many thanks! nomicons/smile
It seem to just work on Mageia 6.  Only tested a few minutes so far: new shema, opening a 0.6 version shema and editing it, save, close, reopen. Print to physical printer, print to pdf.  It seem to use configuration from already installed 0.6 version: project folder, history, user collection.

Noticed the old issue that floating tool bars appear on every desktop. I use Plasma 5.12 with 3x3 desktops. Qt5.9.4.

A minor language quirk: When opening a project there is the dialogue:
"Opening of the project..."
Remove "of " so it becomes: "Opening the project..."

BTW i think it is a good idea to provide checksums.

When exiting, it throws segmentation fault.

10

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Hi,

thanks for your feedback, I updated in the AppImage GCC et Qt libs versions and uploaded new version.
FYI, I use pkg2appimage, I'm having  some troubles with linuxdeployqt for linking element collection, titleblock, etc  at this time.




QElectroTech V 0.70-dev+svn5435

Compilation : GCC 7.3.0 - built with Qt 5.9.5 - run with Qt 5.9.5 using 16 thread(s)

11

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Previous version worked OK per comment 9, and this is output in terminal from where it was launched and then closed:

bash-4.3$ ./QElectroTech_-0.70.r5428.glibc2.14-x86_64.AppImage 
/home/morgan/.local/share/applications/appimagekit-qelectrotech.desktop: warning: value "Editor výkresů elektrických obvodů" for key "Comment[cs]" in group "Desktop Entry" looks redundant with value "Editor výkresů elektrických obvodů" of key "GenericName[cs]"
QSqlDatabase: QSQLITE driver not loaded
QSqlDatabase: available drivers: 
Unable to open the SQLite database  "/home/morgan/.qet//elements_cache.sqlite"  as  "ElementsCollectionCache-0" :  QSqlError("", "Driver not loaded", "Driver not loaded")
Segmenteringsfel (minnesutskrift skapad)
bash-4.3$ 

I dont know the impact of the sql problems; did not notice any usage problems but did not try everything.


The new version fail to launch; after the dialog about wether to integrate this appimage in the system, it exits, and this is found in the terminal:

bash-4.3$ ./QElectroTech_-0.70.r5435.glibc2.14-x86_64.AppImage 
/home/morgan/.local/share/applications/appimagekit-qelectrotech.desktop: warning: value "Editor výkresů elektrických obvodů" for key "Comment[cs]" in group "Desktop Entry" looks redundant with value "Editor výkresů elektrických obvodů" of key "GenericName[cs]"
gtk-update-icon-cache: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /tmp/.mount_QElectDf2G3F/lib/x86_64-linux-gnu/libmount.so.1)
gtk-update-icon-cache: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /tmp/.mount_QElectDf2G3F/lib/x86_64-linux-gnu/libblkid.so.1)
/tmp/.mount_QElectDf2G3F/usr/bin/qelectrotech: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /tmp/.mount_QElectDf2G3F/lib/x86_64-linux-gnu/libbsd.so.0)
bash-4.3$ 

I have glibc 2.22 installed.

12

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Well, thanks.
First version is based on ubuntu Xenial, the last to Bionic.

13

Re: Appimage and/or flatpack to replace some distro specifik packagings?

I it possible to include more in the appimage to make it less system dependent?

14

Re: Appimage and/or flatpack to replace some distro specifik packagings?

I just tried with Linuxdeployqt, isn't finished, but if you could try it, thanks.





QElectroTech V 0.70-dev
Compilation : GCC 7.3.0 - built with Qt 5.10.1 - run with Qt 5.10.1 using 16 thread(s)

15

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Morganol wrote:

I it possible to include more in the appimage to make it less system dependent?

Yes :

qelectrotech/usr/plugins$ tree
.
|-- bearer
|   |-- libqconnmanbearer.so
|   |-- libqgenericbearer.so
|   `-- libqnmbearer.so
|-- iconengines
|   `-- libqsvgicon.so
|-- imageformats
|   |-- kimg_eps.so
|   |-- kimg_exr.so
|   |-- kimg_kra.so
|   |-- kimg_ora.so
|   |-- kimg_pcx.so
|   |-- kimg_pic.so
|   |-- kimg_psd.so
|   |-- kimg_ras.so
|   |-- kimg_rgb.so
|   |-- kimg_tga.so
|   |-- kimg_xcf.so
|   |-- libqgif.so
|   |-- libqicns.so
|   |-- libqico.so
|   |-- libqjpeg.so
|   |-- libqmng.so
|   |-- libqsvg.so
|   |-- libqtga.so
|   |-- libqtiff.so
|   |-- libqwbmp.so
|   `-- libqwebp.so
|-- platforminputcontexts
|   |-- libcomposeplatforminputcontextplugin.so
|   |-- libibusplatforminputcontextplugin.so
|   `-- libqtvirtualkeyboardplugin.so
|-- platforms
|   `-- libqxcb.so
|-- printsupport
|   `-- libcupsprintersupport.so
|-- sqldrivers
|   |-- libqsqlite.so
|   |-- libqsqlmysql.so
|   `-- libqsqlpsql.so
`-- xcbglintegrations
    |-- libqxcb-egl-integration.so
    `-- libqxcb-glx-integration.so


8 directories, 35 files

16

Re: Appimage and/or flatpack to replace some distro specifik packagings?

$ ./QElectroTech_-x86_64.AppImage 
./qelectrotech: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /tmp/.mount_QElectz2Esmr/usr/bin/../lib/libQt5Core.so.5)
bash-4.3$

17

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Hmm, this AppImage was built on my Debian Sid and needs to work on the most recent distributions like Ubuntu 18.04, Debian testing/Unstable, etc.
So I use a older distribution to make AppImage, or https://github.com/AppImage/AppImageKit … pGenerator
or https://github.com/wheybags/glibc_version_header

https://github.com/AppImage/AppImageKit … ase-system

18

Re: Appimage and/or flatpack to replace some distro specifik packagings?

QElectroTech V 0.70-dev
Compilation: GCC 6.3.0 20170516 - built with Qt 5.7.1 - run with Qt 5.7.1 using 16 thread(s)


Debian 9 GLIBC_2.24

19

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Launches cleanly, seem to work correctly (very quick test) and exits cleanly without segfault nomicons/smile  (Mageia 6, Plasma).

20

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Nice ! Thanks for checking the appimage. nomicons/smile

I uploaded latest AppImage : QElectroTech_0.7-r5437-x86_64.AppImage

https://download.tuxfamily.org/qet/builds/AppImage/

21

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Same simple test, same OK result nomicons/smile

22

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Hi,

Just tried the 5437 release on Slackware64-current under KDE5 and after a quick test it seems to work OK!

Dik

23

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Nice, thanks Dik. nomicons/smile

24

Re: Appimage and/or flatpack to replace some distro specifik packagings?

On Windows and macOs OS, it is easy to launch an old version of QET such as "ReadyToUse" or bundle "dmg" to minors adjust and retouch old and big projects that we do not need or want to convert them on recent versions, from done I also sent Appimage for versions 0.5 and 0.6.


Enjoy ! nomicons/smile




https://download.tuxfamily.org/qet/builds/AppImage/

25

Re: Appimage and/or flatpack to replace some distro specifik packagings?

Great!  I put the news here https://wiki.mageia.org/en/QElectroTech#Appimage and also noted it in the forum recently nomicons/smile

0.5 and 0.6 launch cleanly.  0.5 complains in the terminal of symbols saved with later version, as expected.

Is it possible to launch the appimages with some parameter or other trick to make them use different folders of symbols, templates, drawings?