Topic: actual Version does not find common element-collection

in the actual debian-version (qelectrotech_0.90.r7473-1_amd64.deb qelectrotech-data_0.90.r7473-1_all.deb) QET does not find the default system-wide element-collection.

The directory where the collection is stored is "/usr/share/qelectrotech/elements",
the setting is "default" but in the tree I only see my user-elements.

In the config-file I find these settings:

[elements-collections]
common-collection-path=default
custom-collection-path=/home/ich/Projekte/qet/elements
custom-tbt-path=/home/ich/Projekte/qet/titleblocks

When I set the directory to "custom" (/usr/share/qelectrotech/elements) all elements are shown...

Post's attachments

Bildschirmfoto_2021-12-23_22-46-22.png, 8.25 kb, 267 x 130
Bildschirmfoto_2021-12-23_22-46-22.png 8.25 kb, 45 downloads since 2021-12-23 

Re: actual Version does not find common element-collection

Yes one of my colleague report me this issue.
I think they come from this commit :  https://git.tuxfamily.org/qet/qet.git/c … f509e23332

I will take a look this week.

Re: actual Version does not find common element-collection

I saw the same thing when I upgraded to this version.
But I saw great improvement on loading elements collection under Windows ... same like Linux ..

Windows :
https://qelectrotech.org/forum/viewtopi … 614#p15614

My Debian worstation :
https://qelectrotech.org/forum/viewtopi … 563#p15563

Re: actual Version does not find common element-collection

Probably a wrong path is returned by the function.
But when I will fix this problem, the performance improvement will stay nomicons/smile.
Happy to see that now, even if qet stay speeder in linux than windows, the performance on this last one is now closer to linux.

Re: actual Version does not find common element-collection

Fixed