2019-08-26 02:07 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000074QElectroTechDiagram Editorpublic2016-05-14 01:52
Reporterfirewalker 
Assigned Toscorpio810 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformGNU/LinuxOSArchlinuxOS Version
Product Version 
Target VersionFixed in Version 
Summary0000074: Segmentation fault upon launching 0.5-rc1
Description

While I can sucessfully build Qelectrotech under Archlinux, it willl segfault upon launching.


 


libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
QETSingleApplication::sendMessage() : QLocalSocket::connectToServer: Connection refused ( qelectrotech-UNKNOWN )
service is "org.kde.StatusNotifierItem-2710-1"
Registering a client interface to the KStatusNotifierWatcher
Segmentation fault (core dumped)

Additional Information(gdb) backtrace
#0  0x00000000 in ?? ()
0000001  0xb79e0f81 in QMenu::actionEvent(QActionEvent*) () from /usr/lib/libQt5Widgets.so.5
0000002  0xb7892cfa in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000003  0xb79e798a in QMenu::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000004  0xb784ac6a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000005  0xb7850330 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000006  0xb6d2a8cf in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
0000007  0xb78891c9 in QWidget::insertAction(QAction*, QAction*) () from /usr/lib/libQt5Widgets.so.5
0000008  0xb788933e in QWidget::addAction(QAction*) () from /usr/lib/libQt5Widgets.so.5
0000009  0x081316b5 in ?? ()
0000010 0x081362f4 in ?? ()
0000011 0x0807d4c9 in ?? ()
0000012 0xb6744497 in __libc_start_main () from /usr/lib/libc.so.6
0000013 0x08084aa5 in ?? ()
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000127

firewalker (reporter)

I forgot to mention that I am using Qt 5.5.1, and that  it segfaults while showing the start-up screen. It says Loading... Folios editor.

~0000128

firewalker (reporter)

The problem is with function buildSystemTrayMenu(); in qetapp.cpp file, line 127.


 


 


Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
0000001  0xb79e0f81 in QMenu::actionEvent(QActionEvent*) () from /usr/lib/libQt5Widgets.so.5
0000002  0xb7892cfa in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000003  0xb79e798a in QMenu::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000004  0xb784ac6a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000005  0xb7850330 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
0000006  0xb6d2a8cf in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5                                                                 
0000007  0xb78891c9 in QWidget::insertAction(QAction*, QAction*) () from /usr/lib/libQt5Widgets.so.5                                                                        
0000008  0xb788933e in QWidget::addAction(QAction*) () from /usr/lib/libQt5Widgets.so.5                                                                                     
0000009  0x081483ec in QETApp::buildSystemTrayMenu (this=0xbffff224) at sources/qetapp.cpp:1529                                                                             
0000010 0x0813fdc5 in QETApp::QETApp (this=0xbffff224, argc=@0xbffff310: 1, argv=0xbffff3a4) at sources/qetapp.cpp:127
0000011 0x08126213 in main (argc=1, argv=0xbffff3a4) at sources/main.cpp:34
(gdb) frame 10
0000010 0x0813fdc5 in QETApp::QETApp (this=0xbffff224, argc=@0xbffff310: 1, argv=0xbffff3a4) at sources/qetapp.cpp:127
warning: Source file is more recent than executable.
127     //      buildSystemTrayMenu();
(gdb)

~0000129

scorpio810 (administrator)

<div>libpng warning: iCCP: known incorrect sRGB profile</div>
<div>libpng warning: iCCP: too many profiles</div>
<div>libpng warning: iCCP: too many profiles</div>
<div>libpng warning: iCCP: too many profiles</div>
<div></div>
<div>Strange warning for Qet!</div>

~0000131

scorpio810 (administrator)

Mainstream problem, not upstream.
+Notes

-Issue History
Date Modified Username Field Change
2015-11-12 20:33 firewalker New Issue
2015-11-14 12:46 firewalker Note Added: 0000127
2015-11-14 14:11 firewalker Note Added: 0000128
2015-11-14 21:38 scorpio810 Note Added: 0000129
2016-01-02 19:13 scorpio810 Note Added: 0000131
2016-01-02 19:13 scorpio810 Status new => resolved
2016-01-02 19:13 scorpio810 Resolution open => fixed
2016-01-02 19:13 scorpio810 Assigned To => scorpio810
2016-05-14 01:52 scorpio810 Status resolved => closed
+Issue History