1 (edited by Flurk 2019-03-27 20:48:38)

Topic: Unable to safe my "project"

Every time I try to safe I get a pop-up stating "the file was opened read-only and thus will not be written".

The only way to close the program is selecting the option "discard". 

No idea what I do wrong...

2 (edited by Calypso 2019-03-27 21:18:55)

Re: Unable to safe my "project"

which operating system do you have and which version of Qelectrotech? Where did you get the drawing from and did you create it yourself and then save it as normal?

Yours sincerely

3 (edited by Nuri 2019-03-28 10:20:43)

Re: Unable to safe my "project"

@ Flurk:

you can not edit the elements provided in the QET collection. They are in read-only mode.
If you want to edit these elements, please drag&drop the whole QET collection into the user collection (from the collection panel).

Post's attachments

user_collection.png, 28.05 kb, 460 x 267
user_collection.png 28.05 kb, 204 downloads since 2019-03-28 

Re: Unable to safe my "project"

Dear Stebo and Nuri: thank you for the reply!

I'm using QElectro tech on a bootcamp partition on my Mac. Operating system is Windows 7 Ultimate. The version of Qelectrotech is 5.11.2 (it should be the latest version straight from the QET site).
I'm creating a new one-line drawing from the electrical installation of my house. Afterwards I want to draw a situation schedule (meaning a schedule of all switches, receptacles, etc with there position in my house). In Belgium you need to have these drawing from the electrical situation of your home.
From the moment I drag a symbool onto my "drawing board" it seems as if it chances to modified... No idea how I can save a "project" as "normal"

Even when I try to safe a new project, without even draw one symbol from the collection, it fails to save.

I found a database with all Belgian synbols for electrical installation (AREI symbols) and tried to paste it in the user collection but I don't succeed. I can add it to the QET Collection folder.

I even tried to install the program again without the QET Collection folder but still I can't save a project...

No idea if it is Windows related... At the moment I try to recover some photo's from an eternal HDD and can't interrupt this program. Once it is finished I will try to install the MAC version of QET...

Re: Unable to safe my "project"

I also have the same problem both with debian testing and ubuntu neon.
Open qet, create a new project and save it to get the default.
Save an existing project, or save a new project to an existing work well.

6 (edited by Flurk 2019-03-29 22:54:59)

Re: Unable to safe my "project"

I did install QET on my Mac (latest version straight form the QET site) and also on MAC I have the same problems... I open a new project and try to save it WITHOUT drawing any line or dragging a symbol in it (so a clean workspace) and even when doing so I get the message " the file was opened read-only and thus will not be written". Strange: a new project created by QET itself, saved without any drawing action, gives an error...

I'm afraid I have to look for another program: QET doesn't work for me, neither in Windows nor in Mac

Re: Unable to safe my "project"

Solved with comit 5813.
Wait for new build.

Very strange, I don't know why the previous code bug.

Re: Unable to safe my "project"

Thank you Joshua! I wil wait (and hope ;-)  )

Re: Unable to safe my "project"

Hum ! why saving a empty project ! .... nomicons/wink

Re: Unable to safe my "project"

Hi Scorpio810,

the reason why I tried saving an empty project was to check if one of the collections would be the cause of the error. Since there weren't any drawings made or symbols added in the project, it had to be a fault of the program itself. Another cause could be the OS. I tried it on Windows PC and on a Mac and in both cases I couldn't save the file.

Re: Unable to safe my "project"

I did install version 06 (the former one) and now I'm able to save the project...

So for me the problems are solved with this and thus this topic can be closed.

Thank you all for trying to help me!! Much appreciated!

Have a fine day!

Re: Unable to safe my "project"

You didn't try latest 0.7-dev?

Re: Unable to safe my "project"

I did try the 0.7-dev version Scorpio but that one gave me all the troubles. The 0.6 version (on Mac) works fine for the moment.