Topic: Set new conductor properties from project properties

Hello,

In New Folio section from project properties I have set the multiline conductor properties and once the conductor is created, only the display text is set, I use the text formula %autonum for text and all the rest  of variables are text. The Function, Voltage/Protocol and conductor section are not set at the generated conductors.

I am using QElectroTech V 0.80-DEV+364012848 AppImage on Ubuntu 20. Is it there any bug or I am not using QElectroTech correctly?

Re: Set new conductor properties from project properties

Hello,

The Function, Voltage/Protocol was removed  recently in element variable
https://git.tuxfamily.org/qet/qet.git/p … 0a7898e503
and we can't hacks report element to make this useful example here, because tagg was removed too, that 's not good :


For me is a big problem to loose this feature, if Joshua have an idea to restore my old hack?

https://qelectrotech.org/forum/viewtopi … 410#p12410

Re: Set new conductor properties from project properties

The workaround is to create this report element in 0.6 version, but only run with tagg function..
Maybe is because in dynamic text widget we have only element information function..

https://download.tuxfamily.org/qet/forum_img_2/tagg_report.png

Post's attachments

Attachment icon 02going_arrow.elmt 1.58 kb, 78 downloads since 2020-11-08 

Re: Set new conductor properties from project properties

Laurent, essayes le dernier commit, ça devrais corriger le problème.

Re: Set new conductor properties from project properties

Super, on peux maintenant re créer des renvois avec en plus les propriétés des conducteurs reliés : fonction, couleur du conducteur, section du conducteur directement depuis la version 0.8-dev, mais malheureusement tension/protocol ne fonctionne pas encore.