Topic: Symbols rendered in black and white

Hi all,

I'm using archlinux and I recently manually updated QElectrotech to 0.7.0 (the exact PKGBUILD I used can be found as a comment on its AUR page).
The symbols are now rendered partly in black and partly in white, hence with white background I don't see all the lines. I attached a screenshot with grey background to be able to see the issue. When printing to PDF, all seems to be rendered properly though.

Not sure is relevant but I'm using a dark Qt theme and my graphic card is an Intel HD 630.

Post's attachments

Attachment icon grey.png 55.87 kb, 27 downloads since 2019-08-19 

Re: Symbols rendered in black and white

I believe you accidentally have turned on the view option which does exacly that: to be able to see difference between white part of symbol, and background.

I have not used 0.7, but in 0.6 that was a button in the top menu.

Re: Symbols rendered in black and white

Did you use kde?
In the past, I play with kvantum and dark theme, and I've got the same issue.
If it's the case, try with the default kde theme.

Re: Symbols rendered in black and white

Hi Morganol,

thank you for your answer. If I understood you properly, we are talking about two different things. Please, correct me if I am wrong.

I'm not concerned about the grey background... I purposedly enabled it to view the problem. I attached a new image that hopefully will explain the problem better. On the left you'll see a threephase switch: it is the inter_sectionneur_tri element from the standard library opened in the element editor. On the right there is the same element rendered on my schematic. Why?

Re: Symbols rendered in black and white

Joshua wrote:

Did you use kde?
In the past, I play with kvantum and dark theme, and I've got the same issue.
If it's the case, try with the default kde theme.

Hi Joshua,

I'm on xfce. I'll try to disable the dark theme and see if this solves the problem.

Re: Symbols rendered in black and white

ntd wrote:

I'm on xfce. I'll try to disable the dark theme and see if this solves the problem.

Yes, it seems to be the dark theme. I opened a new issue because searching for "dark" returned no results.

Many thanks for the hint, Joshua.

Re: Symbols rendered in black and white

Put this style.css in your ~/.qet folder and disable use system color in settings.
Not perfect but it should be better.

https://download.tuxfamily.org/qet/forum_img/black-theme.png

Post's attachments

Attachment icon style.css 13.63 kb, 74 downloads since 2019-08-20 

Re: Symbols rendered in black and white

Many thanks for the hint, scorpio810. I didn't know I can use custom CSS code.

I ended up using the following CSS fragment that seems to make the diagram editor perfectly usable:

QGraphicsView {
  color: #000;
}

I will update the issue accordingly.

Re: Symbols rendered in black and white

Great. ;-)