QElectroTech Versione 0.3

Guida di avvio rapido di QElectroTech

Pagina principale del progetto: www.qelectrotech.org

1.1. Panoramica

QElectroTech è un'applicazione per la creazione di schemi elettrici. L'editor contiene elementi che possono essere riutilizzati per creare componenti personalizzati. Crea schemi unifilari e multifilari. Può gestire gli schemi dei progetti di automazione in diversi linguaggi di programmazione, gli schemi dei circuiti elettronici e altro ancora.

Per ottimizzare la gestione degli schemi e degli elementi è utilizzato il formato XML. QElectroTech è un programma libero distribuito sotto licenza GNU/GPL versione 2, per i seguenti sistemi: MS Windows, GNU/Linux e MacOS.

1.2. Installazione

La versione aggiornata di QElectroTech per GNU/Linux può essere scaricata da http://qelectrotech.org/download.html, scegliendo tra i sorgenti e le versioni compilate per le varie distribuzioni. Per MSWindows sono disponibili i file d'installazione (.exe) e archivi compattati (.zip). La collezione di simboli comprende circa 1.560 nuovi elementi. Ci sono i simboli per pneumatica, idraulica, di processo, solari, refrigerazione, ecc.

1.3. Commenti

Gli elementi di libreria forniti con QElectroTech vengono forniti con la formula “AS IS” (Così come sono) senza garanzie. È Permessa la modifica del programma e degli elementi da parte degli utenti senza condizioni e senza tenere conto della licenza degli schemi finali creati. Nel caso di utilizzo di tutte o parte delle librerie di componenti QElectroTech, per scopi diversi dalla creazione di schemi elettrici, occorre rispettare i termini della licenza CC-BY: Questo lavoro è rilasciato sotto una licenza Creative Commons Attribution 3.0. Per leggere una copia della licenza, si rimanda al sito web: http://creativecommons.org/licenses/by/3.0/ o scrivere una lettera a Creative Commons, 171 Second Street, Suite 300, San Francisco, California 94105, USA.

2 Disegno degli schemi

2.1. Descrizione dell'editor degli schemi

Barra del menu principale - menu standard che permetta l'accesso a tutte le funzioni dell'applicazione.

Barra degli strumenti - contiene le icone per le funzioni di base per la creazione e modifica degli schemi.

Pannello degli elementi - oltre a contenere gli elementi da inserire negli schemi, permette di modificare le categorie e gli elementi.

Elenco progetti ed elementi dello schema - lista di tutti gli elementi inclusi nel progetto corrente o utilizzati nel progetto.

Collezione di QElectroTech - una collezione dei componenti di base forniti con l'applicazione.

Collezione utente - une collection di componenti creati dell'utente e collegati all'applicazione.

Lista Azioni - riepilogo di tutte le azioni eseguite con la possibilità di ripristinare una situazione precedente.

Cartiglio - tabella che contiene le informazioni sullo schema: titolo, autore, nome del file, numero di pagina corrente e pagine totali.

2.2. Creazione di un nuovo progetto

Selezionare File → Nuovo

oppure fare clic su

- Verrà creato un nuovo progetto chiamato “Progetto senza titolo”. Selezionando dal menu → Progetto → Proprietà del progetto si aprirà una finestra di dialogo in cui sarà possibile digitare il Titolo del progetto, alcuni dati personalizzati per il cartiglio, le impostazioni per la numerazione dei conduttori, ecc. Confermando i dati inseriti, questi appariranno negli schemi creati successivamente.

2.3. Creazione di un nuovo schema

Creando un nuovo progetto, il sitema crea automaticamente un nuovo schema denominato “Senza titolo”. Per Modificare il nome dello schema corrente (diverso da quello dell'intero progetto) sono disponibile diverse alternative:

  • fare clic su
  • selezionare il menu Modifica → Proprietà dello schema
  • premere Ctrl + L
  • doppio clic sull'etichetta (in alto a sinistra) con il nome dello schema da modificare
  • facendo clic destro nell'area di disegno dello schema e scegliendo, dal menù contestuale → Proprietà dello schema

A questo punto è possibile inserire o modificare il nome dello schema e altri dati per il cartiglio ed i conduttori, similmente alle proprietà del progetto.

2.4. Inserimento di elementi

Fare clic sull'elemento desiderato dall'elenco a sinistra, trascinarlo sullo schema (tenendo premuto il bottone del mouse) e rilasciare il pulsante nella posizione desiderata. Successivamente, è possibile fare clic sull'elemento inserito per spostarlo o eventualmente ruotarlo utilizzando il menu Modifica → Ruota oppure fare clic su o ancora premere SPAZIO.

2.5. Aree di testo

Orientamento e impostazione della posizione della casella di testo rispetto all'elemento.




Se fosse necessario variare l'orientamento del testo associato ad un elemento, è possibile variarlo in qualsiasi momento. Selezionare Modifica → Orientare i testi e indicare l'angolo di rotazione desiderato nella finestra di dialogo che si sarà aperta.




Dopo aver selezionato l'orientamento desiderato è possibile spostare la casella di testo rispetto all'elemento. Per fare questo, selezionare la casella di testo, e poi fare clic nuovamente sul testo e trascinare il campo per posizionarlo correttamente posto. Durante lo spostamento un alone di colore blu indica l'elemento a cui è legato il testo. Una volta rilasciato il bottene del mouse, verrà memorizzata la posizione del testo rispetto all'elemento. Infatti provando a spostare l'elemento, il testo si sposterà di conseguenza, mantenendo la distanza appena definita.

2.6. Inserire i conduttori

Per inserire un conduttore, posizionare il cursore del mouse sul terminale di uno dei due elementi che si vogliono collegare. Il punto di partenza del conduttore sarà evidenziato da un punto blu, premere il tasto sinistro del mouse e trascinare il cursore sul terminale del secondo elemento che si desidera collegare. Solo dopo la comparsa del punto verde o arancione è possibile rilasciare il pulsante del mouse.

Un punto verde indica che il dispositivo viene connesso per la prima volta.

Il colore arancione indica la presenza di altre connessioni.

Il punto rosso indica che il collegamento non sarà permesso.

Se nelle proprietà del conduttore è stata selezionata l'opzione multifilare, verrà visualizzato anche il campo di testo relativo al conduttore e un doppio clic permette di modificarne il contenuto.

In caso fosse necessario cambiare il percorso seguito dal conduttore, è necessario selezionarlo con un semplice clic su di esso con il tasto sinistro del mouse. il conduttore cambia colore diventando rosso, evidenziando in verde la maniglie che è possibile utilizzare per cambiare appunto il percorso.

Per ripristinare i persorsi originali dei conduttori, dopo aver selezionato i conduttori interessati, fare clic su Modifica → Resetta i conduttori, oppure con clic destro sopra il conduttore e scegliere la voce Resetta i conduttori dal menu contestuale, o ancora selezionando l'icona .

3 Creazione o modifica di elementi

3.1. Editor degli elementi

Barra del menu principale - menu standard che fornisce l'accesso a tutte le funzioni dell'applicazione.

Barra degli strumenti - contiene le icone per le funzioni di base la creazione e la modifica di elementi.

Barra degli strumenti di disegno - contiene l'immagine da inserire, come ad esempio: linea, rettangolo, ellisse, cerchio, poligono, arco, testo, casella di testo, e il punto di Rapture.

Area di disegno - area in cui si crea un elemento disegnando le varie parti che lo compongono.

Area delle informazioni - mostra le informazioni e impostazionedella parte selezionata nell'area di disegno.

Lista delle parti - un elenco di tutti le parti grafiche che compongono l'elemento.

Cronologia - Scheda che contiene l'elenco di tutte le operazioni effettuate sull'elemento, con la possibilità di annullare le operazioni e tornare allo stato precedente.

3.2. Creare un nuovo elemento

Nel pannello degli elementi, fare clic destro sulla collezione utente e selezionare dal menu contestuale Nuova categoria oppure selezionare l'icona dalla barra degli strumenti.

Nella finestra di dialogo che appare, il primo passo richiede la scenta della collezione in cui inserire l'elento da creare.

Al secondo passo occerre indicare il nome del nuovo elemento.

Questo sarà il nome con cui il file sarà salvato, non il nome visualizzato, da QET, nel pannello degli elementi.

Nella schermata successiva si possono inserire le traduzioni del nome del nome dell'elemento nelle varie lingue, facendo clic sul pulsante Aggiunge linea.

Premere il pulsante OK e le informazioni inserire saranno memorizzate.

A questo punto si accede all'editor interno di QelectroTech in cui disegnare direttamente il nuovo elemento.

3.2.1 Esempio di creazione di un elemento

Esempio di creazione di un elemento

Facendo clic sull'icona è possibile tracciare due linee verticali lunghe 10 punti e distanti tra loro 20 punti. Selezionando un tratto, cioè una singola parte dell'elemento, questo viene evidenziato in rosso e nel pannello delle informazioni vengono mostrate le opzioni i dati relativi alla parte selezionata.

Dopo aver selezionato l'icona tracciare un arco di cerchio con diametro orizzontale e verticale di 5 punti. Il metodo più pratico è quello di disegnare un piccolo cerchio aiutandosi anche con le immagini qui riprodotte. Successivamente è possibile correggere le misure agendo nel pannello delle informazioni (sulla destra), nei campi diametro orizzontale=5, verticale=5, angolo di partenza=0 e angolo=180.

Con lo strumento di selezione creare altre 3 copie dell'arco appena creato. Utilizzare allo scopo la combinazione di tasti CTRL+C (copia) e CTRL+V (incolla). Procedere poi al posizionamento allineando i tratti tra le due linee verticali.

Inserire ora i terminali avendo cura di orientarli correttamente, tramite le solite opzioni nel pannello delle informazioni. Nel nostro caso il terminale superiore sarà orientato a nord, mentre quello inferiore a sud.

Per inserire del testo è possibile scegliere tra il testo fisso e l'area ti testo. Il primo è a tutti gli effetti un elemento grafico e seguirà la rotazione e lo spostamento dell'elemento, ma non può essere modificato se non all'interno dell'editor degli elementi. L'area di testo, invece, è un testo associato all'elemento, ma può essere personalizzato con un semplice doppio clic (durante la normale creazione di uno schema) e può essere diverso per ogni elemento inserito nello schema stesso, oltre alla possibilità di orientamento e posizionamento indipendente dall'elemento a cui è associato (in base anche all'opzione riguardante la rotazione dell'area di testo, nell'editor degli elementi).

Selezionando l'icona dalla barra degli strumenti, è possibile aggiungere o modificare la traduzione dell'elemento nelle varie lingue. Lo stesso risultato si ottiene con la pressione dei tasti CTRL+E oppure del menu Modifica → Modifica nomi.

Per impostare le opzioni di rotazione dell'elemento disponibile l'icona oppure la combinazione CTRL+T. In questo modo è possibile stabilire quali posizioni può assumere un elemento sullo schema (es. impedire qualsiasi rotazione o permettere solo una posizione verticale).

Un'altra opzione della stassa finestra di dialogo è quella di permettere le connessioni interne, ossia la possibilità di collegare tra loro i terminali delle stesso elemento.

Infine con la pressione di CTRL+Y si possono inserire informazioni sull'autore, eventuali licenze legate all'elemento, ecc.

4 Stampa dello schema

4.1. Selezione del tipo di stampa

Per stampare uno schema, selezionare dal menu File → Stampa, o fare clic sull'icona .

Si aprirà un dialogo in cui scegliere la funzione desiderata: stampa tramite una stampante fisica, creazione di un file .pdf oppure salve come file postscript (.ps).

Sotto alle opzioni di stampa è visualizzato l'eventuale cartella in cui sarà salvato il file. Il bottone a destra permette di modificare il percorso, scegliendo anche differenti supporti esterni.

Se si sceglie di stampare su carta tramite stampante fisica il passo successivo sarà di selezionare la stampante (tra quelle disponibili nel sistema operativo), per poi passare all'anteprima di stampa.

Se la scelta è stata di creare un file (PDF o PS) si passa direttamente all'anteprima.

4.2 Anteprima di stampa

Prima di procedere alla stampa (o creazione del formato digitale) è possibile decidere cosa stampare.

L'ultima schermata presenta una nutrita serie di opzioni che permettono di scegliere quali schemi (pagine) stampare, se includere il cartiglio, la cornice, la griglia, ecc.

Altre impostazione permettono di gestire al meglio alcuni aspetti grafici come il bordo ai lati dello schema, ecc.

5 Esportare lo schema

QElectroTech può esportare lo schema creato utilizzando diversi formati: PNG (*. PNG), JPEG (*. Jpg), Bitmap (*. BMP), SVG (*. Svg).

Selezionare File → Esportare, poi dalla finestra di dialogo che appare scegliere il tipo di file adatto all'uso che se ne vuole fare, impostando anche la cartella di destinazione ed altre opzioni.

QElectroTech 0.3

Documento originale: 08/06/2011 - QElectroTech 0.3 Démarrage rapide 14/14

Imprimer/exporter