QElectroTech

Version 0.3

1 Introduction

1.1. QElectroTech

  - QElectroTech is an application for creating circuit diagrams . Editor has elements that can be used to create custom components. Creates a single line or multi-line system diagrams

electrical drawings for automation projects in different languages

  - Programming , electronic circuit diagrams , and more. For saving schemes and elements used in an XML format . QElectroTech is free software released under the GNU / GPL version 2 , for the following systems: MS Windows , GNU / Linux and MacOS .

1.2. Installation

    - The latest version of QElectroTech can be downloaded from http://qelectrotech.org/download.html for GNU / Linux, you can download the source files or finished packages for various distributions . MS Windows versions are available : Installation (exe ) and ready to use ( zip) . On the home page are ready to download electrical components , pneumatic and others.

1.3. Notes

    - Library of components supplied with QElectroTech , is in the form of “ AS IS ” without any warranties . Allowed to edit , modify and users elements without condition and regardless of the final license created schemas. In the case of the use of all or part of the component libraries QElectroTech for purposes other than the creation of electrical schematics , observe the terms of the license CC -BY : This work is licensed under a Creative Commons Attribution 3.0 license . To view a copy of the license, please visit our website: http://creativecommons.org/licenses/by/3.0/ or send a letter to Creative Commons , 171 Second Street , Suite 300 , San Francisco, California 94105 , USA.

2 Edit Schema

2.1. Description Schema Editor






the main menu bar - standard menu which allows you to access all the functions of the application.

Main Toolbar - contains icons for basic functions of creating and editing diagrams.

Toolbar Elements panel - lets you create and edit categories and components.

List schemes and design elements - contains a list of all schemes included in the active project and used items in the project.

Collection of QElectroTech - a collection of components supplied with with the application.

Collection of user - a collection of connected components application by the user.

History of operations - tab which lists all made and withdrawn transactions.

Title Block - table which contains the basic data schema : title, author , date , file name , number and number of pages .

2.2. Create a new project

    - Choose from a menu File → New → or click



- will create a new project called “Project bases the title” . Then select the menu → Project → Project Properties , in the open window , type the name of the project , the type of cable and title block data . Completed title block data will appear in the newly created schemas.





2.3. Create new scheme

    - Create a new project is created scheme called “ scheme with no name ” , select from the menu → Edit → Properties schema or click


- enter or change the schema name and other data title block. The following diagrams add to the project by choosing → Project → Insert diagram or by right-clicking on the active project in the Information pane and select from the popup menu → Insert diagram .

2.4. Inserting elements

    - Left-click on the selected item from the collection , then drag it and drop the release button in the editing of schedules . In the next step, click on the inserted item by dragging it with the left mouse button and rotate it to the desired position using the menu → Edit → Rotate or click


-



2.5. Text boxes

Type designation of the item in the box.





If, during the creation of the option is not selected to maintain

text field level despite trading item poleobróci together

with the item. Select from the menu → Edit → Text Orientation and select the angle of rotation

text relative to the open window .





After selecting the desired angle can change the position of the text box

relative to the element. To do this, select the text box , the

a decorated piece with the mouse and drag the field to the right

place . Offset relative to the field is indicated by shading

the item in the color blue. Position the text box depends

the position of the element, the element moves the shift field

text .





2.6. Insert wires

    - To insert the cable , place the mouse cursor over the point capture the element that you want to connect. Then when you see the flag in blue, press the left mouse button and move the cursor over the point capture the element you want to call , after the appearance of the marker in green or orange , release the mouse button.



tag in green appears as the device is connected for the first time ,

orange appears when the element is no longer calls made earlier.

Red indicates that the link is not allowed. If the

Cable properties is selected multi-line field appears

Text to enter the cable markings , with this option selected

Single- A visual indication of the number and type of cable . In the event

need to change the cable route , check the cord dragging over it

the mouse with the left button , the wire turns

red and green handles will appear , which you can use to change route

wires.



In order to return to the specified routes cables automatically select the menu →

Edit → Restore route cables , or click the icon

3 Editing items


3.1. Description Editor

elements




the main menu bar - standard menu , which allows you to all functions of the application .

Main Toolbar - contains icons for basic functions the creation and editing of elements.

Drawing toolbar - contains the image to be inserted , such as:

line, rectangle , ellipse, circle , polygon , arc , text , text box , and point Rapture .

Active Area - an area that is edited item .

Information about lots - displays the selected options of the graphic edited feature .

List the item- list of all the graphics included in the element.

History of operations - tab which lists all made and withdrawn transactions.


3.2. Creating a new element

In the Contents pane , right-click on the collection of user

and select from the popup menu → New Category or press the icon



then enter the internal name and description. When you click on the Insert button

row , you can enter the name in other languages.





Press the OK button in the collection of user category will be created .

Then right-click on the collection of user

and select from the popup menu → New Item , or click the icon



In the next wizard window to create a new item, determine : Category

for an item , the file name, the name of the item , size and active area and

orientation . Then click the icon editor elements


and draw two vertical lines with a length of 10 points (to scale ) , remote

separated by 20 points.



If one of the element is selected (red ), the panel

The information is displayed options that part. Then click the icon



and put a bow in the editing area . In the Info panel set in the options ;

horizontal diameter : 5, vertical diameter of 5 , the start angle 0 and angle : 180 then

arc ready to drag the vertical line as shown.



Select the arc copy three times, and drag in the space between the vertical

lines.


then to insert the capture points click the icon



and insert by clicking the edit area in the next step, we set the panel

Information on the orientation of the capture points north and south , respectively

to the destination. Orientation capture points indicates the direction

the attachment of the element. Capture points are red ,

marked change color to blue.




Select the toolbar graphic or text Text Box




and put in the display area , giving it the opportunity to mark an item

when you insert it into the diagram . The text box is different from the text that can be

edited after inserting an item into the schematic editor and can maintain

vertical position despite the rotation of the schema editor . text Size

Default character and the other options we set in the Information pane when you select text

or text box.



Since the active area extends beyond the size of the element (text box )

select from menu → Edit → Edit size and active area or click

icon



and change the size to a size larger than the active area . active

area is marked in purple.

\ \


When you choose → Edit → Edit name , or click the icon



You can change the name of the item , or add the names in other languages.

After selecting the menu → Edit → Edit orientation or click the icon



You can set the direction of rotation of acceptable Editor schemas.

Additionally, you can allow or deny the exercise of internal connections .

Select from the menu → Edit → 's Information or by clicking



allows you to enter information about the author, licenses, etc. In the Schema Editor

refresh the collection by clicking on the icon

4 Printing patterns


4.1. Select the type of print

    - To print the chart , select from the menu → File → Print or click on the icon ,



- open a window where you select the type of output. There are three types of printing: printing to a physical printer print the PDF file and print to a PostScript file .








print option bar and viewing patterns - allows you to view

and hiding the print options , and changes in the preview schemas.

Design patterns List - You can select and deselect schemes

print .

Rendering Options - options for changing the appearance of the printed pattern.

Print Options - options for changing the print to fit the page.


5 Export Schema

QElectroTech can export diagrams to image files , such as:

PNG % % ( * % %. Png ) JPEG % % ( * % %. Jpg ) bitmap % % ( * % %. Bmp) SVG % % ( * % %. svg ) .

Select from the menu File → Export → and then in the window that opens, select

file type to which you want to export the diagram , select the destination folder

set other options and press Export .




08.06.2011 quickstart_qet_pl_html_7ee93e7f.png_qelectrotech 0.3 - Quick Start 14/14


Imprimer/exporter
Langages
Traductions de cette page: