QElectroTech

Wersja 0.3




Szybki start























Autor


QElectroTech Team


Licencja


Niniejsza praca jest licencjonowana na zasadach Creative Commons Attribution 3.0 License: http://creativecommons.org/licenses/by/3.0/deed.en




Ikona(Logo)


Nuno Pinheiro nuno@nuno-icons.com








QElectroTech


Strona domowa projektu: www.qelectrotech.org



Autorzy QElectroTech


Pomysłodawca: Benoit Ansieau benoit@qelectrotech.org


Programowanie: Xavier Guerrin xavier@qelectrotech.org



















Spis treści

1. Wstęp 3

1.1. QElectroTech 3

1.2. Instalacja 3

1.3. Uwagi 4

2. Edycja schematów 4

2.1. Opis edytora schematów 4

2.2. Tworzenie nowego projektu 5

2.3. Tworzenie nowego schematu 5

2.4. Wstawianie elementów 5

2.5. Pola tekstowe 6

2.6. Wstawianie przewodów 7

3. Edycja elementów 9

3.1. Opis edytora elementów 9

3.2. Tworzenie nowego elementu 9

4. Drukowanie schematów 13

4.1. Wybór rodzaju wydruku 13

4.2. Podgląd wydruku 13

5. Eksport schematów 14



1. Wstęp


1.1. QElectroTech

  1. QElectroTech to aplikacja do tworzenia schematów elektrycznych. Posiada edytor elementów, który można wykorzystywać do tworzenia własnych elementów. Umożliwia tworzenie jednokreskowych lub wielokreskowych schematów instalacji

elektrycznych, rysunków projektów dla automatyki w różnych językach

  1. programowania, schematów obwodów elektronicznych i innych. Do zapisywania schematów i elementów wykorzystywany jest format XML. QElectroTech jest oprogramowaniem darmowym dostępnym na licencji GNU/GPL version 2, dla systemów: MS Windows, GNU/Linux i MacOS.


1.2. Instalacja

  1. Najnowszą wersję QElectroTech można pobrać ze strony http://qelectrotech.org/download.html dla systemy GNU/Linux można pobrać pliki źródłowe lub gotowe pakiety dla różnych dystrybucji. Dla systemu MS Windows dostępne są wersje: instalacyjna (exe) i gotowa do użycia (zip). Na stronie domowej znajdują się gotowe do pobrania elementy instalacji elektrycznej, pneumatycznej i inne.

1.3. Uwagi

  1. Biblioteka elementów dostarczana wraz z QElectroTech, jest w formie „taka jaka jest”, bez żadnych gwarancji przydatności. Dozwolona jest edycja, modyfikacja i użytkownie elementów bez żadnych warunków i bez względu na końcową licencję tworzonych schematów. W przypadku wykorzystywania całości lub części biblioteki elementów QElectroTech do innych celów niż tworzenie schematów elektrycznych, należy przestrzegać warunków licencji CC-BY: Niniejsza praca jest licencjonowana na zasadach Creative Commons Attribution 3.0 license. Aby zobaczyć kopię licencji, należy odwiedzić stronę internetową: http://creativecommons.org/licenses/by/3.0/ lub wysłać list do Creative Commons, 171 Second Street, Suite 300, San Francisco, Kalifornia 94105, USA.




2. Edycja schematów


2.1. Opis edytora schematów






Pasek menu głównego – standardowe menu, które umożliwia dostęp

do wszystkich funkcji aplikacji.

Główny pasek narzędzi – zawiera ikony podstawowych funkcji związanych

z tworzeniem i edycją schematów.

Pasek narzędzi panelu Elementy– umożliwia tworzenie i edycję kategorii

i elementów.

Lista schematów i elementy projektu– zawiera listę wszystkich schematów

wchodzących w skład aktywnego projektu oraz elementy wykorzystane

w projekcie.

Kolekcja elementów QElectroTech– kolekcja elementów dostarczana wraz

z aplikacją.

Kolekcja elementów użytkownika– kolekcja elementów dołączonych

do aplikacji przez użytkownika.

Historia wykonanych operacji – zakładka w której znajduje się lista wszystkich

wykonanych i cofniętych operacji.

Tabelka rysunkowa – tabela w której znajdują się podstawowe dane

o schemacie: tytuł, autor, data, nazwa pliku, numer i liczba stron.


2.2. Tworzenie nowego projektu

  1. Wybierz z menu → Plik → Nowy lub kliknij ikonę



- zostanie utworzony nowy projekt o nazwie „Projekt baz tytułu”. Następnie wybierz z menu → Projekt → Właściwości projektu, w otwartym oknie wpisz nazwę projektu, typ przewodu i dane tabelki rysunkowej. Wypełnione dane tabelki rysunkowej będą się pojawiać w nowo utworzonych schematach.





2.3. Tworzenie nowego schematu

  1. W nowo utworzonym projekcie zostaje utworzony schemat o nazwie „Schemat bez nazwy”, wybierz z menu → Edycja → Właściwości schematu lub kliknij ikonę


- wpisz lub zmień nazwę schematu i pozostałe dane tabelki rysunkowej. Kolejne schematy dodajemy do projektu wybierając z menu → Projekt → Wstaw schemat lub przez kliknięcie prawym przyciskiem myszy na aktywnym projekcie w panelu Informacje i wybraniu z menu kontekstowego → Wstaw schemat.


2.4. Wstawianie elementów

  1. Kliknij lewym przyciskiem myszy na wybranym elemencie z kolekcji, następnie przeciąg go i upuść zwalniając przycisk w obszarze edycji schematów. W kolejnym kroku zaznacz wstawiony element przeciągając nad nim myszką z wciśniętym lewym przyciskiem i obróć go do pożądanej pozycji wybierając z menu → Edycja → Obróć lub kliknij ikonę


-



2.5. Pola tekstowe

Wpisz oznaczenie elementu w polu tekstowym.





Jeżeli w czasie tworzenia elementu nie została zaznaczona opcja utrzymywania

pola tekstowego w poziomie pomimo obrotu elementu, poleobróci się wraz

z elementem. Wybierz z menu → Edycja → Orientacja tekstui wybierz kąt obrotu

tekstu względem elementu w otwartym oknie.





Po wybraniu odpowiedniego kąta możemy zmienić pozycję pola tekstowego

względem elementu. W tym celu należy zaznaczyć pole tekstowe, przy

odznaczonym elemencie i za pomocą myszki przeciągnąć pole w odpowiednie

miejsce. Przesunięcie pola względem elementu jest sygnalizowane zabarwieniem

się elementu na kolor niebieski. Pozycja pola tekstowego jest uzależniona

od pozycji elementu, przesunięcie elementu powoduje przesunięcie pola

tekstowego.





2.6. Wstawianie przewodów

  1. Aby wstawić przewód, umieść kursor myszy nad punktem pochwycenia elementu, który chcesz połączyć. Następnie po pojawieniu się znacznika w kolorze niebieskim, naciśnij lewy przycisk myszy i przenieś kursor nad punkt pochwycenia elementu z którym chcesz połączyć, po pojawieniu się znacznika w kolorze zielonym lub pomarańczowym zwolnij przycisk myszy.



Znacznik w kolorze zielonym pojawia się gdy element jest łączony pierwszy raz,

pomarańczowy pojawia się gdy element ma już połączenia wykonane wcześniej.

Kolor czerwony oznacza, że dane połączenie jest zabronione. Jeżeli we

właściwościach przewodu zaznaczona jest opcja Wielokreskowy, pojawi się pole

tekstowe do wpisania oznaczenia przewodu, przy zaznaczonej opcji

Jednokreskowy pojawi się graficzne oznaczenie ilości i typu przewodów. W razie

konieczności zmiany tras przewodów, zaznacz dany przewód przeciągając nad nim

wskaźnik myszy z wciśniętym lewym przyciskiem, przewód zmieni kolor na

czerwony i pojawią się zielone uchwyty, za pomocą których można zmieniać trasy

przewodów.



W celu powrotu do automatycznie wytyczonych tras przewodów wybierz z menu →

Edycja → Przywróć trasy przewodów lub kliknij ikon



















3. Edycja elementów


3.1. Opis edytora elementów




Pasek menu głównego– standardowe menu, które umożliwia dostęp do

wszystkich funkcji aplikacji.

Główny pasek narzędzi – zawiera ikony podstawowych funkcji związanych

z tworzeniem i edycją elementów.

Pasek narzędzi rysunkowych – zawiera części graficzne do wstawienia, typu:

linia, prostokąt, elipsa, okrąg, wielokąt, łuk, tekst, pole tekstowe i punkt

pochwycenia.

Aktywny obszar – obszar, który zajmuje edytowany element.

Informacje o częściach – wyświetla opcje zaznaczonej części graficznej

edytowanego elementu.

Lista części elementu – lista wszystkich części graficznych wchodzących w skład

elementu.

Historia wykonanych operacji – zakładka w której znajduje się lista wszystkich

wykonanych i cofniętych operacji.


3.2. Tworzenie nowego elementu

W panelu Elementy, kliknij prawym przyciskiem myszy na kolekcję użytkownika

i wybierz z menu kontekstowego → Nowa kategoria lub naciśnij ikonę



następnie wpisz nazwę wewnętrzną i nazwę. Po kliknięciu na przycisk Wstaw

wiersz, można wpisać nazwy w innych językach.





Naciskamy przycisk OK, w kolekcji użytkownika pojawi się utworzona kategoria.

Następnie klikamy prawym przyciskiem myszy na kolekcji użytkownika

i wybieramy z menu kontekstowego → Nowy element lub klikamy ikonę



W kolejnych oknach asystenta tworzenia nowego elementu, ustalamy: kategorię

dla elementu, nazwę pliku, nazwę elementu, rozmiar i aktywny obszar oraz

orientację. Następnie w edytorze elementów klikamy ikonę


i rysujemy dwie pionowe linie o długości 10 punktów (w powiększeniu), oddalone

od siebie o 20 punktów.



Jeżeli jedna z części elementu jest zaznaczona (kolor czerwony), to w panelu

Informacje wyświetlane są opcje tej części. Następnie klikamy ikonę



i wstawiamy łuk w obszarze edycji. W panelu Informacje ustawiamy w opcjach;

średnica poziomo: 5, średnica pionowo: 5, początek kąta: 0 i kąt: 180. Następnie

gotowy łuk przeciągamy do pionowej linii jak na rysunku.



Zaznaczamy łuk kopiujemy trzy razy i przeciągamy w miejsca pomiędzy pionowymi

liniami.


Następnie w celu wstawienia punktów pochwycenia klikamy ikonę



i wstawiamy klikając w obszarze edycji, w kolejnym kroku ustalamy w panelu

Informacje orientację punktów pochwycenia na północ i południe, odpowiednio

do miejsca przeznaczenia. Orientacja punktów pochwycenia wskazuje na kierunek

przyłączenia przewodów do elementu. Punkty pochwycenia mają kolor czerwony,

zaznaczone zmieniają kolor na niebieski.




Wybieramy z paska narzędzi graficznych Tekst lub Pole tekstowe




i wstawiamy w aktywnym obszarze, daje to możliwość oznaczenia elementu

po wstawieniu go do schematu. Pole tekstowe różni się od tekstu tym, że może być

edytowane po wstawieniu elementu do edytora schematów i może utrzymywać

pionową pozycję pomimo obrotu elementu w edytorze schematów. Wielkość tekstu

domyślny znak i inne opcje ustalamy w panelu Informacje po zaznaczeniu tekstu

lub pola tekstowego.



Ponieważ aktywny obszar wykracza poza rozmiar elementu (pole tekstowe)

wybieramy z menu → Edycja → Edytuj rozmiar i aktywny obszar lub klikamy

ikonę



i zmieniamy wielkość rozmiaru tak aby był większy niż aktywny obszar. Aktywny

obszar jest oznaczony kolorem fioletowym.





Po wybraniu z menu → Edycja → Edytuj nazwę lub kliknięciu ikony



można zmienić nazwę elementu lub dodać nazwy w innych językach.

Po wybraniu z menu → Edycja → Edytuj orientację lub kliknięciu ikony



można ustawić dopuszczalne kierunki obrotu elementu w Edytorze schematów.

Dodatkowo można zezwolić lub zabronić na wykonywanie połączeń wewnętrznych.

Wybranie z menu → Edycja → Informacje autora lub kliknięcie ikony



umożliwia wpisanie informacji o autorze, licencji itp. W oknie Edytora schematów

odświeżamy kolekcję przez kliknięcie ikony

4. Drukowanie schematów


4.1. Wybór rodzaju wydruku

  1. W celu wydrukowania schematu wybierz z menu → Plik → Drukuj lub kliknij ikonę,



- otworzy się okno w którym wybieramy rodzaj wydruku. Do wyboru są trzy rodzaje wydruku: wydruk na drukarce fizycznej, wydruk do pliku PDF i wydruk do pliku PostScript.



4.2. Podgląd wydruku






Pasek opcji wydruku i podglądu schematów – umożliwia wyświetlanie

i ukrywanie opcji wydruku, oraz zmiany w podglądzie schematów.

Lista schematów projektu – umożliwia zaznaczanie i odznaczanie schematów,

do wydruku.

Opcje renderowania – opcje zmieniające wygląd drukowanego schematu.

Opcje wydruku– opcje zmieniające dopasowanie wydruku do strony.


5. Eksport schematów

QElectroTech umożliwia eksport schematów do plików graficznych takich jak:

PNG(*.png), JPEG(*.jpg), bitmapa(*.bmp), SVG(*.svg).

Wybierz z menu → Plik → Eksport a następnie w oknie, które się otworzy wybierz

typ pliku do jakiego chcesz eksportować schemat, wskaż katalog docelowy,

ustaw pozostałe opcje i naciśnij przycisk Eksport.




8.06.2011 QElectroTech 0.3 - Szybki start 14/14


Imprimer/exporter
Langages
Traductions de cette page: