1

Topic: Missing standard electrical elements

Hi, please be gentle with me as this is my first post!

p, li { white-space: pre-wrap; I have used qelectrotech some time ago and updated to the latest version Qt version 5.9.5. in Linux Mint 19.

I do not have a lot of experience with the software in general, but the standard electrical drawing components do not seem to be available. The QET title blocks and user title blocks and user collection are visible in the elements panel, but when I click on them nothing is showing.

I am probably doing something wrong here, but I would appreciate any help from the forum.

Best regards,
WM7793

2

Re: Missing standard electrical elements

I think that I have managed to get the symbols displayed. It's just a question of me not being familiar with the software.

Another trivial question: on the line drawing tool, every line drawn is a dashed one rather than solid.

I have checked in the settings of the (configure new project) , (conductor) it is already set to solid line.

Could somebody please help me on this?

Best regards,
WM7793

3

Re: Missing standard electrical elements

Hi, 

you confond conductors and the basic shapes, isn't the same.


See this Videos, they can help you.
https://qelectrotech.org/forum/viewtopic.php?id=1075 

4

Re: Missing standard electrical elements

Thank you Scorpio810 for your reply.

I have the family over for the weekend at the moment, but I look forward to studying the video link for a better understanding of the software.

Best regards,
Wm7793

5

Re: Missing standard electrical elements

Other Vidéos you can see :
https://www.youtube.com/user/scorpio8101/videos

Best regards,
Laurent

6 (edited by WM7793 2019-03-11 20:24:26)

Re: Missing standard electrical elements

Thank you Laurent for your replies.

I am sorry to have to ask these simple questions.

But can you please tell me why that when I draw a simple rectangle, the default is always a dashed line, and that one of the sides of the rectangle is always "broader" than the others,  despite double checking in the configuration of QElectotech,  under "new project", "conductor", "appearance" set to "solid" line

Apologies for asking very basic questions.

Best regards,
Clive

7

Re: Missing standard electrical elements

Hi Laurent, an update to my silly question.

I have noticed when I zoom into the drawing, the lines are indeed the same thickness.

But I would like the default to be a solid line.

Best regards,
Clive

8

Re: Missing standard electrical elements

@ Laurent:

I agree that a solid line default is the best standard for all basic shapes.
I assume that a solid line pattern is the most used in the most cases.

9

Re: Missing standard electrical elements

@ Nuri :

It's easy to have SolidLine for basic shape to default.

Patch :

--- sources/qetgraphicsitem/qetshapeitem.cpp
+++ sources/qetgraphicsitem/qetshapeitem.cpp
@@ -45,7 +45,7 @@
  if (type == Polygon) m_polygon << m_P1 << m_P2;
     setFlags(QGraphicsItem::ItemIsMovable | QGraphicsItem::ItemIsSelectable | QGraphicsItem::ItemSendsGeometryChanges);
  setAcceptHoverEvents(true);
- m_pen.setStyle(Qt::DashLine);
+ m_pen.setStyle(Qt::SolidLine);
  //ensure handlers are always above this item
  connect(this, &QetShapeItem::zChanged, [this]()
  {

10

Re: Missing standard electrical elements

Hi, Is this patch maybe already available?
It would be very useful to use the default properties for lines and squares.

11

Re: Missing standard electrical elements

Revision: 5918
Author:   scorpio810
Date:     2019-06-12 15:16:54 +0200 (Wed, 12 Jun 2019)
Log Message:
-----------
Basic shapes : set solid line pattern by default

12

Re: Missing standard electrical elements

Thank you sir. I appreciate that!