1 (edited by Max 2018-07-21 22:28:56)

Topic: Element text move with every file open, NEW ONE

Hello folks,

i found a problem, similar to 

https://qelectrotech.org/forum/viewtopi … 8268#p8268

The effect appears when alignment is right and auto sequence has changed.
Like 'location machine' or 'machine' name has changed.

The element text use then the old position from left side of text and not the right side.

My Version:0.70-dev+svn5449 debian stretch x64

Post's attachments

elements.png, 29.03 kb, 554 x 260
elements.png 29.03 kb, 217 downloads since 2018-07-21 

Re: Element text move with every file open, NEW ONE

hi,
I can't reproduce the bug, can you give us the procedure to reproduce it.

3 (edited by Max 2018-08-06 14:10:13)

Re: Element text move with every file open, NEW ONE

Hello Joshua,

sorry for my bad description.

Generate element name pattern with machine and/or location.
Folio has not set a name to machine or location.
Place element that have elementname with right alignment.
Set name in folio machine and/or location.
Save and close.
Reopen.
Tada.

Same Problem when delete or change name in lenght.

4 (edited by b.w.v.leeuwen 2018-09-18 21:09:15)

Re: Element text move with every file open, NEW ONE

Some of the element texts move when copied, as shown in the attached file.
First the upper line is made and the texts are set (show Label, Voltage / Protocol, Function)
Hereafter the complete row is copied. When linked, the texts have been replaced.
Each line is a copy of the line above.
It seams like a little bug.

Post's attachments

Attachment icon Screenshot from 2018-09-18 12-47-26.png 130.15 kb, 92 downloads since 2018-09-18 

Re: Element text move with every file open, NEW ONE

To me it seems that it has to do with the alignment. When it is set LEFT there is no problem, but when set CENTERED of RIGHT it goes wrong. The Position-X of the copied field has changed.
Interesting to me is, when I change the Alignment of a certain text, nor the Position-values change, nor the text moves. I would expect that the Position-X and Position-Y make op the reference point, from witch the alignment takes place. Now it works in some other way, but the element loses this information when copied. Maybe it is best to make the Position-X and Y the reference point of the alignment. This would probably solve the problem.