1

Topic: Délier éléments et texte dynamique

Bonjour,
J'utilise la version 0.7dev-5307.
Lorsque je lie 2 reports de folio ensemble le 'lien-texte-report' s'affiche : normal
Lorsque je les délie, l'ancien 'lien-texte-report' reste toujours affiché. Du coup si on n'y fait pas attention, on ne sait pas si le report est valide ou non car meme en enregistrant et rouvrant le programme, il reste affiché (meme s'il n'est pas lié)
Si j'efface le texte, alors je perd le texte dynamique qu'il faut recréer, mais il faut le faire sur les 2 reports.
Ne faudrait-il pas lorsqu'on délie un report, remettre le texte dynamique à sa valeur initiale (comme si on le créait) sur les 2 reports ?
Y a t'il une autre solution qui n'affiche pas le texte du folio-report si le report n'est pas lié, ou faut-il faire attention à chaque déliement ?
J'ai peut-etre aussi raté quelque chose dans l'utilisation des textes dynamiques.

2

Re: Délier éléments et texte dynamique

Salut, non ce n'est pas normal, le texte doit effectivement revenir à sa valeur de base.
Je n'ai pas eu le temps de tester, si j'ai le temps je règle ça ce soir, sinon demain.

3 (edited by friskolon 2018-04-10 20:32:48)

Re: Délier éléments et texte dynamique

Rebonjour,

J'ai remarqué aussi un autre soucis avec les reports de folio, l'affichage ne se met pas toujours à jour.
Voici l'explication du problème :
Je crée 1 projet vide avec 3 folios.
Sur le 1er folio, je met 1 'report suivant' et sur le 3ème folio, je met 1 'report précédent'.
Je lie les 2 reports ensemble, l'affichage est correct sur les 2 folios.
Si je supprime le folio 2, l'affichage du report sur le folio 1 n'est plus bon, il affiche le report en folio 3 au lieu du folio 2.
Si j'enregistre le projet et que je le réouvre, l'affichage est cependant correct.
Est-ce que cela peut etre corrigé en meme temps.
J'ai trouvé ce bug car je cable une armoire avec un schéma qui contient le problème, ca m'a paru bizarre car les renvois étaient tous bons. J'ai donc recherché d'ou cela pouvait venir.

4

Re: Délier éléments et texte dynamique

Problème réglé commit 5329
Merci du retour.

5

Re: Délier éléments et texte dynamique

Merci, ca fonctionne, mais maintenant il y a quelque chose qui me choque/perturbe.
Lorsque je pose 1 report, le texte dans label est vide, rien ne s'affiche sur l'écran (ca le faisait avant la modif)
Si je délie 1 report, le texte '_' s'affiche maintenant à l'écran et le label est devenu '_'

Est-ce normal qu'il y ait un comportement différent de la valeur label, entre le fait de poser un report ou de délier un report. Soit ca doit afficher '_' soit rester vide dans les 2 cas (poser ou délier) : ????

6

Re: Délier éléments et texte dynamique

J'ai mis "_" par défaut pour signaler que le "label" est nulle, mais après réflexion, effectivement il semble plus logique que le texte soit vide.
C'est corrigé.

7

Re: Délier éléments et texte dynamique

Merci