Topic: DXFtoQUT binary requires QT 5.12 / 5.9 possible?

Hello,
first of all congratulations to QElectrotech!
I am just working with it for 2 weeks, and up to now it works great for me!

I just want to make some Weidmüller terminals as elements.
I have seen there is a brand new version of DXFtoQED, but this requires QT 5.12.
Would it be possible to compile it with QT 5.9 ?
5.12 its quite new and not supported by my Linux Mint 19.1

Regards

Markus

Re: DXFtoQUT binary requires QT 5.12 / 5.9 possible?

https://download.tuxfamily.org/qet/buil … lmt/linux/

Re: DXFtoQUT binary requires QT 5.12 / 5.9 possible?

Hello Markus,

Why don't you compile it yourself this plugin with your Qt libs installed?
Maybe nou need to insttall before qtbase5-dev, qt5-qmake, libqt5svg5-dev,libqt5sql5-mysql

Is a little program and compile is very quick.

Wget source tarball and extract it
go to this directory and mkdir build/ && cd build
run
qmake ../DXFtoQET.pro

Now compile it
make -j$(nproc)

If compile ok, move this binary in ~/.qet/ folder