Topic: Warning:Debian packages repository informations

Bonjour,
Pour information, Debian 8 aka "Jessie" est sortie le week end dernier, mes chroots de compilation des paquets Debian sont calqués sur les dépôts unstable et stable de debian.
Pour ceux qui sont sur des Mint, ou de vielles Ubuntu comme la 14.04, ou la 14.10, il est fortement conseillé de passer sur ce dépôt:

deb http://debian.qelectrotech.org/qet/debian/ stable main

Au fur à mesure de la descente des paquets de Debian experimental vers unstable (sid) vous allez vous retrouver dans le dépôt Qet unstable avec le binaire compilé avec les librairies  GCC 5.x et  Qt en 5.4, ou  bientôt avec Qt 5.x.
Ceux en Debian unstable ou sur la dernière Ubuntu (15.04 avec backports) peuvent continuer comme avant avec le dépôt:

deb http://debian.qelectrotech.org/qet/debian/ unstable main

Enjoy!

Re: Warning:Debian packages repository informations

Bonjour,
Une nouvelle propriété à été ajouté pour les éléments maître " commutateur/bouton".
Un nouveau champ pour l'export de la nomenclature vient d’être ajouté dans le widget de renseignement de l’élément: "fonction"
http://download.tuxfamily.org/qet/forum_img/button_master.png

3 (edited by galexis 2015-05-01 08:24:11)

Re: Warning:Debian packages repository informations

scorpio810 wrote:

Bonjour,
Une nouvelle propriété à été ajouté pour les éléments maître " commutateur/bouton".

Quel nouveau "genre" d'Xref cela va-t-il ajouter ou autre fonction ?

4 (edited by NVieville 2015-05-01 19:36:57)

Re: Warning:Debian packages repository informations

Bonjour,

Suis sous Ubuntu 14.04 LTS, et depuis la dernière mise à jour, j'obtiens le message d'erreur suivant :

Les paquets suivants ont des dépendances non satisfaites :
qelectrotech : Dépend: libqt5core5a (>= 5.3.0) mais 5.2.1+dfsg-1ubuntu14.2 est installé.

Pour information :

#cat /etc/apt/sources.list.d/qelectrotech.list
deb http://debian.qelectrotech.org/qet/debian/ stable main

#dpkg -l qelectrotech
ii  qelectrotech               0.40.r3766-2       amd64              Electric schematic editor
#dpkg -l libqtcore4
ii  libqtcore4:amd64           4:4.8.5+git192-g08 amd64              Qt 4 core module
#dpkg -l libqt5core5a
ii  libqt5core5a:amd64         5.2.1+dfsg-1ubuntu amd64              Qt 5 core module

Il semblerait que la dernière version de Qelectrotech de la branche stable du dépôt Debian ne soient plus liée à une version de Qt présente sur Ubuntu 14.04.
Cette version de Ubuntu est la LTS. Elle sera mise-à-jour jusque juillet 2016, date à laquelle nous pourrons passer à la version LTS suivante.
D'ici là je crains que nous soyons scotché à cette version de Qt.
Que faire ?

Par avance merci de votre réponse.

Je reste à disposition pour toute question à ce sujet.

Cordialement,


--
NVieville

Re: Warning:Debian packages repository informations

Bonjour,
Il te faut installer ce PPA pour avoir Qt5 sur ta 14.04:

deb http://ppa.launchpad.net/packetlost/qt-opensource/ubuntu trusty main 

Laurent

Re: Warning:Debian packages repository informations

galexis wrote:
scorpio810 wrote:

Bonjour,
Une nouvelle propriété à été ajouté pour les éléments maître " commutateur/bouton".

Quel nouveau "genre" d'Xref cela va-t-il ajouter ou autre fonction ?

Comme les éléments maîtres: bobines, protections, sauf que tu pourras là aussi choisir ou afficher les Xrefs.
C'est fréquent que les contacts d'un bouton poussoir, commutateur se trouvent ailleurs dans les schémas, ce nouveau type permet de les relier sans passer par des bidouilles.

Re: Warning:Debian packages repository informations

OK. Effectivement cela évitera les bidouilles.
Concernant les bornes auto ? Des avancées ?
Merci.
Cordialement.

Re: Warning:Debian packages repository informations

Pas encore, à ce que je sais.