Topic: Appimage not working

Hi, I've tried to install the stable version of Qelectrotech 0.8 on 18.04 Ubuntu, but the appimage doesn't run (it's asking for `GLIBC_2.28' not found)

I've also tried the snap installation method, and it installs, but won't allow me to save a project.

Has anyone else had this and fixed it?

Re: Appimage not working

I dont have experience from Ubuntu nor snap but a couple workaround suggestions:

(I just tried and QElectroTech_0.8-r7124-x86_64.AppImage do work for me in Mageia 7)

Have you tried other QET versions in Appimage form, i.e 0.9 dev or 0.7 - do they work?

Can you use Ubuntu or Debian packages from https://qelectrotech.org/download.html ?

Do flatpak work for you? (works for me but I dont know if Ubuntu support it)

Next option is to compile it yourself.


That said, yes optimally an Appimage should contain all it need...  There was a while the Appimage did not work for me on Mageia, but it got fixed. Also there it complained on GLIBC version https://qelectrotech.org/forum/viewtopi … 8344#p8344

Re: Appimage not working

https://qelectrotech.org/forum/viewtopi … 381#p14381

You can't upgrade your old 18.04 version?

Re: Appimage not working

Flatpak on Ubuntu:  https://flatpak.org/setup/Ubuntu/
And then https://qelectrotech.org/forum/viewtopi … 226#p11226
Will give you QET 0.9 dev

Re: Appimage not working

Thanks everyone!
I got it working by upgrading to ubuntu 20.