Re: QElectrotech is freezing / loading time library elements

Joshua wrote:

Martin work on a harness feature and if I remember well add terminal number.

Is it the intention to be able to do this?
https://www.youtube.com/watch?v=vWnTZy1gbxw

Re: QElectrotech is freezing / loading time library elements

Rather this I think:
https://youtu.be/x5daIL7qtmM

Re: QElectrotech is freezing / loading time library elements

martin wrote:

My ideas:
1) Add to each terminal in the element an unique identifier (id)

Maybe instead of using newly created id's to connect using
uiid/<terminal_id> or something similar? To have it unique
2) Make somehow a database where all cables are defined
- dialog to add/delete/edit cables (color, diamerter, manufacturer, voltage
...)

3) Property dialog for wires to select the wire from the database
- automatically changing color of the cable
4) export wiring BOM
...) extra: Creating tables like in (rapidharness.com) to show the
connectivity
...) extra: Maybe adding to each terminal minimum and maximum wire diameter
to automatically check

Re: QElectrotech is freezing / loading time library elements

I think this summed it up:
https://geekandpoke.typepad.com/.a/6a00d8341d3df553ef0168eabe2192970c-pi

OK, enough laughs (but it is sometimes necessary), I'll move on to the doc first.
In the meantime I may be able to learn something.

Re: QElectrotech is freezing / loading time library elements

In Windows 10

The problem in Windows 10 is Windows security files ( MsMpEng.exe = Antimalware Service Executable )
Only I have windows defender.


see
Windows icon > All Apps > Windows System > task Manager > details

The first time Qelectrotech  starts, MsMpEng.exe starts too, slowing Qelectrotech loading libraryfiles.
The second time when Qelectrotech starts up, MsMpEng.exe no longer starts up, so Qelectrotech load the libraryfiles faster.

Re: QElectrotech is freezing / loading time library elements

Interesting, but how can improve this?


Method II: Prevent Windows Defender from scanning a specific folder on your system
https://www.dell.com/support/article/fr … ns?lang=en