Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
doc:test_en [17/09/2013 12:17]
scorpio810 [2.4. Inserting elements]
doc:test_en [20/11/2014 13:02] (Version actuelle)
Ligne 1: Ligne 1:
 +{{ QuickStart_QET_pl_html_7ee93e7f.png?​189x189 }}  ** QElectroTech **
  
 +** Version 0.3 **
 +
 +
 +====== 1 Introduction ======
 +
 +===== 1.1. QElectroTech =====
 +
 +  - QElectroTech is an application for creating circuit diagrams . Editor has elements that can be used to create custom components. Creates a single line or multi-line system diagrams
 +
 +electrical drawings for automation projects in different languages
 +
 +  - Programming , electronic circuit diagrams , and more. For saving schemes and elements used in an XML format . QElectroTech is free software released under the GNU / GPL version 2 , for the following systems: MS Windows , GNU / Linux and MacOS .
 +
 +===== 1.2. Installation =====
 +
 +    - The latest version of QElectroTech can be downloaded from [[ http://​qelectrotech.org/​download.html|http://​qelectrotech.org/​download.html ]] for GNU / Linux, you can download the source files or finished packages for various distributions . MS Windows versions are available : Installation (exe ) and ready to use ( zip) . On the home page are ready to download electrical components , pneumatic and others.
 +
 +===== 1.3. Notes =====
 +
 +    - Library of components supplied with QElectroTech , is in the form of " AS IS " without any warranties . Allowed to edit , modify and users elements without condition and regardless of the final license created schemas. In the case of the use of all or part of the component libraries QElectroTech for purposes other than the creation of electrical schematics , observe the terms of the license CC -BY : This work is licensed under a Creative Commons Attribution 3.0 license . To view a copy of the license, please visit our website: [[ http://​creativecommons.org/​licenses/​by/​3.0/​|http://​creativecommons.org/​licenses/​by/​3.0/​ ]] or send a letter to Creative Commons , 171 Second Street , Suite 300 , San Francisco, California 94105 , USA.
 +
 +====== 2 Edit Schema ======
 +
 +===== 2.1. Description Schema Editor =====
 +
 +\\ \\ {{QuickStart_QET_pl_html_97e07c97.png?​529x398 }}\\ {{QuickStart_QET_pl_html_e6e54e50.gif }}{{QuickStart_QET_pl_html_ec90e32f.gif }}{{QuickStart_QET_pl_html_99f8de48.gif }}{{QuickStart_QET_pl_html_cec09fca.gif }}{{QuickStart_QET_pl_html_2b88ca9c.gif }}{{QuickStart_QET_pl_html_9bb2cc8d.gif }}{{QuickStart_QET_pl_html_7c36ebbe.gif }}{{QuickStart_QET_pl_html_981c1f49.gif }}{{QuickStart_QET_pl_html_b5c5c556.gif }}\\ \\ ** the main menu bar ** - standard menu which allows you to access all the functions of the application.
 +
 +** ** Main Toolbar - contains icons for basic functions of creating and editing diagrams.
 +
 +Toolbar ** ** Elements panel - lets you create and edit categories and components.
 +
 +** List schemes and design elements ** - contains a list of all schemes included in the active project and used items in the project.
 +
 +Collection of QElectroTech ** ** - a collection of components supplied with  with the application.
 +
 +Collection of user ** ** - a collection of connected components application by the user.
 +
 +History of operations ** ** - tab which lists all made and withdrawn transactions.
 +
 +Title Block ** ** - table which contains the basic data schema : title, author , date , file name , number and number of pages .
 +
 +===== 2.2. Create a new project =====
 +
 +    - Choose from a menu // ** File → New → ** // or click
 +
 +\\ {{ QuickStart_QET_pl_html_7b7e564c.png?​19x19 }} \\ - will create a new project called ** "​Project bases the title" ** . Then select the menu // ** → Project → Project Properties ** // , in the open window , type the name of the project , the type of cable and title block data . Completed title block data will appear in the newly created schemas.
 +
 +\\ {{ QuickStart_QET_pl_html_81308120.png?​378x280 }} \\ \\ \\ 
 +===== 2.3. Create new scheme =====
 +
 +    - Create a new project is created scheme called ** " scheme with no name " ** , select from the menu // ** → Edit → Properties schema ** // or click
 +
 +{{ QuickStart_QET_pl_html_910d67d1.png?​19x19 }} \\ - enter or change the schema name and other data title block. The following diagrams add to the project by choosing // ** → Project → Insert diagram ** // or by right-clicking on the active project in the Information pane and select from the popup menu // ** → Insert diagram ** // .
 +
 +===== 2.4. Inserting elements =====
 +
 +    - Left-click on the selected item from the collection , then drag it and drop the release button in the editing of schedules . In the next step, click on the inserted item by dragging it with the left mouse button and rotate it to the desired position using the menu // ** → Edit → Rotate ** // or click
 +
 +\\     - {{QuickStart_QET_pl_html_58eaadbd.png?​19x19}} \\ {{QuickStart_QET_pl_html_1fdc7138.png?​529x398 }}\\ {{QuickStart_QET_pl_html_65e33218.gif }}{{QuickStart_QET_pl_html_ea870c7a.gif }}\\ \\
 +===== 2.5. Text boxes =====
 +
 +Type designation of the item in the box.
 +
 +\\ {{ QuickStart_QET_pl_html_54f5c383.png?​302x184 }}\\ \\ \\ If, during the creation of the option is not selected to maintain
 +
 +text field level despite trading item poleobróci together
 +
 +with the item. Select from the menu // ** → Edit → Text Orientation ** // and select the angle of rotation
 +
 +text relative to the open window .
 +
 +\\ {{ QuickStart_QET_pl_html_a4360fa0.gif }} {{ QuickStart_QET_pl_html_f3219c73.png?​302x321 }}\\ \\
 +
 +\\ After selecting the desired angle can change the position of the text box
 +
 +relative to the element. To do this, select the text box , the
 +
 +a decorated piece with the mouse and drag the field to the right
 +
 +place . Offset relative to the field is indicated by shading
 +
 +the item in the color blue. Position the text box depends
 +
 +the position of the element, the element moves the shift field
 +
 +text .
 +
 +\\ {{ QuickStart_QET_pl_html_360acf94.png?​302x195 }}\\ {{ QuickStart_QET_pl_html_ba485dd0.gif }}\\ \\ 
 +===== 2.6. Insert wires =====
 +
 +    - To insert the cable , place the mouse cursor over the point capture the element that you want to connect. Then when you see the flag in blue, press the left mouse button and move the cursor over the point capture the element you want to call , after the appearance of the marker in green or orange , release the mouse button.
 +
 +\\ {{ QuickStart_QET_pl_html_e6524446.gif }} {{ QuickStart_QET_pl_html_ca93f543.png?​302x184 }} \\ tag in green appears as the device is connected for the first time ,
 +
 +orange appears when the element is no longer calls made earlier.
 +
 +Red indicates that the link is not allowed. If the
 +
 +Cable properties is selected multi-line ** ** field appears
 +
 +Text to enter the cable markings , with this option selected
 +
 +Single- ** ** A visual indication of the number and type of cable . In the event
 +
 +need to change the cable route , check the cord dragging over it
 +
 +the mouse with the left button , the wire turns
 +
 +red and green handles will appear , which you can use to change route
 +
 +wires.
 +
 +\\ {{ QuickStart_QET_pl_html_92ff2ed8.gif }} {{ QuickStart_QET_pl_html_ca8c20ce.gif }} {{ QuickStart_QET_pl_html_9eb9187c.gif }} {{ QuickStart_QET_pl_html_97e15fd3.png?​302x201 }} \\ In order to return to the specified routes cables automatically select the menu →
 +
 +// ** Edit → Restore route cables ** // , or click the icon
 +
 +
 + ​====== 3 Editing items ======
 +
 +\\ 
 +===== 3.1. Description Editor ===== 
 +elements
 +
 +{{ QuickStart_QET_pl_html_61d9af01.png?​529x398 }} \\ {{ QuickStart_QET_pl_html_27d1c79d.gif }} {{ QuickStart_QET_pl_html_154f78cd.gif }} {{ QuickStart_QET_pl_html_18d8775b.gif }} {{ QuickStart_QET_pl_html_2ec4a2.gif }} {{ QuickStart_QET_pl_html_8d295f69.gif }} {{ QuickStart_QET_pl_html_edfde451.gif }} {{ QuickStart_QET_pl_html_13830663.gif }} {{ QuickStart_QET_pl_html_69e5522c.gif }} \\ \\ ** the main menu bar ** - standard menu , which allows you to all functions of the application .
 +
 +**Main Toolbar** - contains icons for basic functions the creation and editing of elements.
 +
 +**Drawing toolbar** ​ - contains the image to be inserted , such as:
 +
 +line, rectangle , ellipse, circle , polygon , arc , text , text box , and point Rapture .
 +
 +**Active Area** - an area that is edited item .
 +
 +**Information about lots** - displays the selected options of the graphic edited feature .
 +
 +**List the item**- list of all the graphics included in the element.
 +
 +**History of operations** - tab which lists all made and withdrawn transactions.
 +
 +\\ 
 +===== 3.2. Creating a new element =====
 +
 +In the Contents pane , right-click on the collection of user
 +
 +and select from the popup menu // ** → New Category ** // or press the icon
 +
 +\\ {{ QuickStart_QET_pl_html_f0d62e4b.png?​19x19 }} \\ then enter the internal name and description. When you click on the Insert button ** **
 +
 +** row ** , you can enter the name in other languages.
 +
 +\\ {{ QuickStart_QET_pl_html_4ee6886d.png?​189x214 }} \\ \\ \\ Press the OK button in the collection of user category will be created .
 +
 +Then right-click on the collection of user
 +
 +and select from the popup menu // ** → New Item ** // , or click the icon
 +
 +\\ {{ QuickStart_QET_pl_html_14b42e4b.png?​19x19 }} \\ In the next wizard window to create a new item, determine : Category
 +
 +for an item , the file name, the name of the item , size and active area and
 +
 +orientation . Then click the icon editor elements
 +
 +{{ QuickStart_QET_pl_html_2dbdc77.png?​19x19 }} \\ and draw two vertical lines with a length of 10 points (to scale ) , remote
 +
 +separated by 20 points.
 +
 +\\ {{ QuickStart_QET_pl_html_bf1ef4d.png?​113x226 }} \\ If one of the element is selected (red ), the panel
 +
 +The information is displayed options that part. Then click the icon
 +
 +\\ {{ QuickStart_QET_pl_html_bd611772.png?​19x19 }} \\ and put a bow in the editing area . In the Info panel set in the options ;
 +
 +horizontal diameter : 5, vertical diameter of 5 , the start angle 0 and angle : 180 then
 +
 +arc ready to drag the vertical line as shown.
 +
 +\\ {{ QuickStart_QET_pl_html_73d3d90c.png?​113x167 }} {{ QuickStart_QET_pl_html_d8ee18e5.gif }} \\ Select the arc copy three times, and drag in the space between the vertical
 +
 +lines.
 +
 +{{ QuickStart_QET_pl_html_edc63b8e.gif }} {{ QuickStart_QET_pl_html_256ffa1e.png?​117x152 }} {{ QuickStart_QET_pl_html_ea9ff33b.gif }} {{ QuickStart_QET_pl_html_ffb48114.gif }} \\ then to insert the capture points click the icon
 +
 +\\ {{ QuickStart_QET_pl_html_f334c58f.png?​19x19 }} \\ and insert by clicking the edit area in the next step, we set the panel
 +
 +Information on the orientation of the capture points north and south , respectively
 +
 +to the destination. Orientation capture points indicates the direction
 +
 +the attachment of the element. Capture points are red ,
 +
 +marked change color to blue.
 +
 +\\ \\ {{ QuickStart_QET_pl_html_e778a474.png?​113x169 }} {{ QuickStart_QET_pl_html_33caa7f1.gif }} {{ QuickStart_QET_pl_html_1164de73.gif }} \\ Select the toolbar graphic or text Text Box
 +
 +\\ {{ QuickStart_QET_pl_html_1b3465bb.png?​19x19 }} \\ {{ QuickStart_QET_pl_html_34647693.png?​19x19 }} \\ and put in the display area , giving it the opportunity to mark an item
 +
 +when you insert it into the diagram . The text box is different from the text that can be
 +
 +edited after inserting an item into the schematic editor and can maintain
 +
 +vertical position despite the rotation of the schema editor . text Size
 +
 +Default character and the other options we set in the Information pane when you select text
 +
 +or text box.
 +
 +\\ {{ QuickStart_QET_pl_html_f3968b0c.png?​113x223 }} \\ Since the active area extends beyond the size of the element (text box )
 +
 +select from menu // ** → Edit → Edit size and active area ** // or click
 +
 +icon
 +
 +\\ {{ QuickStart_QET_pl_html_ebb3473d.png?​19x19 }} \\ and change the size to a size larger than the active area . active
 +
 +area is marked in purple.
 +
 +\ \ {{ QuickStart_QET_pl_html_4a638f4b.png?​265x165 }} \\ \\ \\ When you choose // ** → Edit → Edit name ** // , or click the icon
 +
 +\\ {{ QuickStart_QET_pl_html_f39cb55c.png?​19x19 }} \\ You can change the name of the item , or add the names in other languages.
 +
 +After selecting the menu // ** → Edit → Edit orientation ** // or click the icon
 +
 +\\ {{ QuickStart_QET_pl_html_ce82cf1e.png?​19x19 }} \\ You can set the direction of rotation of acceptable Editor schemas.
 +
 +Additionally,​ you can allow or deny the exercise of internal connections .
 +
 +Select from the menu ** → Edit → 's Information ** or by clicking
 +
 +\\ {{ QuickStart_QET_pl_html_144612ee.png?​19x19 }} \\ allows you to enter information about the author, licenses, etc. In the Schema Editor
 +
 +refresh the collection by clicking on the icon
 +
 +{{ QuickStart_QET_pl_html_9975aa38.png?​19x19 }} 
 +====== 4 Printing patterns ======
 +
 +\\ ===== 4.1. Select the type of print =====
 +
 +    - To print the chart , select from the menu // ** → File → Print ** // or click on the icon ,
 +
 +\\ {{ QuickStart_QET_pl_html_336602f1.png?​19x19 }} \\ - open a window where you select the type of output. There are three types of printing: printing to a physical printer ** ** ** print the PDF file ** and ** print to a PostScript file . **
 +
 +\\ {{ QuickStart_QET_pl_html_1c309c13.png?​189x160 }} \\ 
 +===== 4.2. Print Preview =====
 +
 +\\ \\ {{ QuickStart_QET_pl_html_b54e6938.png?​529x398 }} \\ {{ QuickStart_QET_pl_html_17588727.gif }} {{ QuickStart_QET_pl_html_8fb2fb73.gif }} {{ QuickStart_QET_pl_html_919fd942.gif }} {{ QuickStart_QET_pl_html_aa733a38.gif }} {{ QuickStart_QET_pl_html_cf849b80.gif }} \\ \\ ** print option bar and viewing patterns ** - allows you to view
 +
 +and hiding the print options , and changes in the preview schemas.
 +
 +Design patterns ** List ** - You can select and deselect schemes
 +
 +print .
 +
 +Rendering ** ** Options - options for changing the appearance of the printed pattern.
 +
 +Print Options ** ** - options for changing the print to fit the page.
 +
 +\\ ====== 5 Export Schema ======
 +
 +QElectroTech can export diagrams to image files , such as:
 +
 +PNG ** ** % % ( * % %. Png ) ** JPEG ** % % ( * % %. Jpg ) bitmap ** ** % % ( * % %. Bmp) ** SVG ** % % ( * % %. svg ) .
 +
 +Select from the menu // ** File → Export → ** // and then in the window that opens, select
 +
 +file type to which you want to export the diagram , select the destination folder
 +
 +set other options and press ** Export ** .
 +
 +\\ {{ QuickStart_QET_pl_html_df59257c.png?​378x184 }} \\ \\ 08.06.2011 // ** {{ QuickStart_QET_pl_html_7ee93e7f.png QElectroTech ? 34x34 }} 0.3 - Quick Start 14/14 ** //
 +
 +\\
Imprimer/exporter
Langages