Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

doc:test [20/11/2014 13:02] (Version actuelle)
Ligne 1: Ligne 1:
 +\\ 
  
 +{{QuickStart_QET_pl_html_7ee93e7f.png?​189x189 }}\\ \\ \\ \\ \\ **QElectroTech**
 +
 +**Wersja 0.3**
 +
 +\\ \\ \\ //**Szybki start**//
 +
 +\\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ **Autor**
 +
 +\\ QElectroTech Team
 +
 +\\ **Licencja**
 +
 +\\ <​code>​
 +Niniejsza praca jest licencjonowana na zasadach Creative Commons Attribution 3.0 License: http://​creativecommons.org/​licenses/​by/​3.0/​deed.en
 +</​code>​
 +
 +\\ \\ \\ **Ikona**(Logo)
 +
 +\\ Nuno Pinheiro [[nuno@nuno-icons.com|nuno@nuno-icons.com]]
 +
 +\\ \\ \\ \\ \\ \\ \\ **QElectroTech**
 +
 +\\ Strona domowa projektu: [[http://​www.qelectrotech.org/​|www.qelectrotech.org]]
 +
 +\\ \\ **Autorzy QElectroTech**
 +
 +\\ Pomysłodawca:​ Benoit Ansieau [[benoit@qelectrotech.org|benoit@qelectrotech.org]]
 +
 +\\ Programowanie:​ Xavier Guerrin [[xavier@qelectrotech.org|xavier@qelectrotech.org]]
 +
 +\\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ **Spis treści**
 +
 +1. Wstęp 3
 +
 +1.1. QElectroTech 3
 +
 +1.2. Instalacja 3
 +
 +1.3. Uwagi 4
 +
 +2. Edycja schematów 4
 +
 +2.1. Opis edytora schematów 4
 +
 +2.2. Tworzenie nowego projektu 5
 +
 +2.3. Tworzenie nowego schematu 5
 +
 +2.4. Wstawianie elementów 5
 +
 +2.5. Pola tekstowe 6
 +
 +2.6. Wstawianie przewodów 7
 +
 +3. Edycja elementów 9
 +
 +3.1. Opis edytora elementów 9
 +
 +3.2. Tworzenie nowego elementu 9
 +
 +4. Drukowanie schematów 13
 +
 +4.1. Wybór rodzaju wydruku 13
 +
 +4.2. Podgląd wydruku 13
 +
 +5. Eksport schematów 14
 +
 +\\ \\ ====== 1. Wstęp ======
 +
 +\\ ===== 1.1. QElectroTech =====
 +
 +  - QElectroTech to aplikacja do tworzenia schematów elektrycznych. Posiada edytor elementów, który można wykorzystywać do tworzenia własnych elementów. Umożliwia tworzenie jednokreskowych lub wielokreskowych schematów instalacji ​
 +
 +elektrycznych,​ rysunków projektów dla automatyki w różnych językach
 +
 +  - programowania,​ schematów obwodów elektronicznych i innych. Do zapisywania schematów i elementów wykorzystywany jest format XML. QElectroTech jest oprogramowaniem darmowym dostępnym na licencji GNU/GPL version 2, dla systemów: MS Windows, GNU/Linux i MacOS. ​
 +
 +\\ ===== 1.2. Instalacja =====
 +
 +    - Najnowszą wersję QElectroTech można pobrać ze strony [[http://​qelectrotech.org/​download.html|http://​qelectrotech.org/​download.html]] dla systemy GNU/Linux można pobrać pliki źródłowe lub gotowe pakiety dla różnych dystrybucji. Dla systemu MS Windows dostępne są wersje: instalacyjna (exe) i gotowa do użycia (zip). Na stronie domowej znajdują się gotowe do pobrania elementy instalacji elektrycznej,​ pneumatycznej i inne. 
 +
 +===== 1.3. Uwagi =====
 +
 +    - Biblioteka elementów dostarczana wraz z QElectroTech,​ jest w formie „taka jaka jest”, bez żadnych gwarancji przydatności. Dozwolona jest edycja, modyfikacja i użytkownie elementów bez żadnych warunków i bez względu na końcową licencję tworzonych schematów. W przypadku wykorzystywania całości lub części biblioteki elementów QElectroTech do innych celów niż tworzenie schematów elektrycznych,​ należy przestrzegać warunków licencji CC-BY: Niniejsza praca jest licencjonowana na zasadach Creative Commons Attribution 3.0 license. Aby zobaczyć kopię licencji, należy odwiedzić stronę internetową:​ [[http://​creativecommons.org/​licenses/​by/​3.0/​|http://​creativecommons.org/​licenses/​by/​3.0/​]] lub wysłać list do Creative Commons, 171 Second Street, Suite 300, San Francisco, Kalifornia 94105, USA. 
 +
 +\\ \\ \\ ====== 2. Edycja schematów ======
 +
 +\\ ===== 2.1. Opis edytora schematów =====
 +
 +\\ \\ {{QuickStart_QET_pl_html_97e07c97.png?​529x398 }}\\ {{QuickStart_QET_pl_html_e6e54e50.gif }}{{QuickStart_QET_pl_html_ec90e32f.gif }}{{QuickStart_QET_pl_html_99f8de48.gif }}{{QuickStart_QET_pl_html_cec09fca.gif }}{{QuickStart_QET_pl_html_2b88ca9c.gif }}{{QuickStart_QET_pl_html_9bb2cc8d.gif }}{{QuickStart_QET_pl_html_7c36ebbe.gif }}{{QuickStart_QET_pl_html_981c1f49.gif }}{{QuickStart_QET_pl_html_b5c5c556.gif }}\\ \\ **Pasek menu głównego** -- standardowe menu, które umożliwia dostęp
 +
 +do wszystkich funkcji aplikacji.
 +
 +**Główny pasek narzędzi** -- zawiera ikony podstawowych funkcji związanych
 +
 +z tworzeniem i edycją schematów.
 +
 +**Pasek narzędzi panelu Elementy**-- umożliwia tworzenie i edycję kategorii
 +
 +i elementów.
 +
 +**Lista schematów i elementy projektu**-- zawiera listę wszystkich schematów
 +
 +wchodzących w skład aktywnego projektu oraz elementy wykorzystane
 +
 +w projekcie.
 +
 +**Kolekcja elementów QElectroTech**-- kolekcja elementów dostarczana wraz
 +
 +z aplikacją.
 +
 +**Kolekcja elementów użytkownika**-- kolekcja elementów dołączonych
 +
 +do aplikacji przez użytkownika.
 +
 +**Historia wykonanych operacji** -- zakładka w której znajduje się lista wszystkich
 +
 +wykonanych i cofniętych operacji.
 +
 +**Tabelka rysunkowa** -- tabela w której znajdują się podstawowe dane
 +
 +o schemacie: tytuł, autor, data, nazwa pliku, numer i liczba stron.
 +
 +\\ ===== 2.2. Tworzenie nowego projektu =====
 +
 +    - Wybierz z menu //**→ Plik → Nowy**// lub kliknij ikonę ​
 +
 +\\ {{QuickStart_QET_pl_html_7b7e564c.png?​19x19}}\\ ​    - zostanie utworzony nowy projekt o nazwie **„Projekt baz tytułu”**. Następnie wybierz z menu //**→ Projekt → Właściwości projektu**//,​ w otwartym oknie wpisz nazwę projektu, typ przewodu i dane tabelki rysunkowej. Wypełnione dane tabelki rysunkowej będą się pojawiać w nowo utworzonych schematach. ​
 +
 +\\ {{QuickStart_QET_pl_html_81308120.png?​378x280 }}\\ \\ \\ ===== 2.3. Tworzenie nowego schematu =====
 +
 +    - W nowo utworzonym projekcie zostaje utworzony schemat o nazwie **„Schemat bez nazwy”**, wybierz z menu //**→ Edycja → Właściwości schematu**//​ lub kliknij ikonę ​
 +
 +{{QuickStart_QET_pl_html_910d67d1.png?​19x19}}\\ ​    - wpisz lub zmień nazwę schematu i pozostałe dane tabelki rysunkowej. Kolejne schematy dodajemy do projektu wybierając z menu //**→ Projekt → Wstaw schemat**// lub przez kliknięcie prawym przyciskiem myszy na aktywnym projekcie w panelu Informacje i wybraniu z menu kontekstowego //**→ Wstaw schemat**//​. ​
 +
 +\\ ===== 2.4. Wstawianie elementów =====
 +
 +    - Kliknij lewym przyciskiem myszy na wybranym elemencie z kolekcji, następnie przeciąg go i upuść zwalniając przycisk w obszarze edycji schematów. W kolejnym kroku zaznacz wstawiony element przeciągając nad nim myszką z wciśniętym lewym przyciskiem i obróć go do pożądanej pozycji wybierając z menu //**→ Edycja → Obróć**// lub kliknij ikonę ​
 +
 +\\     - {{QuickStart_QET_pl_html_58eaadbd.png?​19x19}} \\ {{QuickStart_QET_pl_html_1fdc7138.png?​529x398 }}\\ {{QuickStart_QET_pl_html_65e33218.gif }}{{QuickStart_QET_pl_html_ea870c7a.gif }}\\ \\ ===== 2.5. Pola tekstowe =====
 +
 +Wpisz oznaczenie elementu w polu tekstowym.
 +
 +\\ {{QuickStart_QET_pl_html_54f5c383.png?​302x184 }}\\ \\ \\ Jeżeli w czasie tworzenia elementu nie została zaznaczona opcja utrzymywania
 +
 +pola tekstowego w poziomie pomimo obrotu elementu, poleobróci się wraz
 +
 +z elementem. Wybierz z menu //**→ Edycja → Orientacja tekstu**//i wybierz kąt obrotu
 +
 +tekstu względem elementu w otwartym oknie.
 +
 +\\ {{QuickStart_QET_pl_html_a4360fa0.gif }} {{QuickStart_QET_pl_html_f3219c73.png?​302x321 }}\\ \\ 
 +
 +\\ Po wybraniu odpowiedniego kąta możemy zmienić pozycję pola tekstowego
 +
 +względem elementu. W tym celu należy zaznaczyć pole tekstowe, przy
 +
 +odznaczonym elemencie i za pomocą myszki przeciągnąć pole w odpowiednie
 +
 +miejsce. Przesunięcie pola względem elementu jest sygnalizowane zabarwieniem
 +
 +się elementu na kolor niebieski. Pozycja pola tekstowego jest uzależniona
 +
 +od pozycji elementu, przesunięcie elementu powoduje przesunięcie pola
 +
 +tekstowego.
 +
 +\\ {{QuickStart_QET_pl_html_360acf94.png?​302x195 }}\\ {{QuickStart_QET_pl_html_ba485dd0.gif }}\\ \\ ===== 2.6. Wstawianie przewodów =====
 +
 +    - Aby wstawić przewód, umieść kursor myszy nad punktem pochwycenia elementu, który chcesz połączyć. Następnie po pojawieniu się znacznika w kolorze niebieskim, naciśnij lewy przycisk myszy i przenieś kursor nad punkt pochwycenia elementu z którym chcesz połączyć,​ po pojawieniu się znacznika w kolorze zielonym lub pomarańczowym zwolnij przycisk myszy. ​
 +
 +\\ {{QuickStart_QET_pl_html_e6524446.gif }}{{QuickStart_QET_pl_html_ca93f543.png?​302x184}}\\ Znacznik w kolorze zielonym pojawia się gdy element jest łączony pierwszy raz,
 +
 +pomarańczowy pojawia się gdy element ma już połączenia wykonane wcześniej.
 +
 +Kolor czerwony oznacza, że dane połączenie jest zabronione. Jeżeli we
 +
 +właściwościach przewodu zaznaczona jest opcja **Wielokreskowy**,​ pojawi się pole
 +
 +tekstowe do wpisania oznaczenia przewodu, przy zaznaczonej opcji
 +
 +**Jednokreskowy** pojawi się graficzne oznaczenie ilości i typu przewodów. W razie
 +
 +konieczności zmiany tras przewodów, zaznacz dany przewód przeciągając nad nim
 +
 +wskaźnik myszy z wciśniętym lewym przyciskiem,​ przewód zmieni kolor na
 +
 +czerwony i pojawią się zielone uchwyty, za pomocą których można zmieniać trasy
 +
 +przewodów.
 +
 +\\ {{QuickStart_QET_pl_html_92ff2ed8.gif }}{{QuickStart_QET_pl_html_ca8c20ce.gif }}{{QuickStart_QET_pl_html_9eb9187c.gif }}{{QuickStart_QET_pl_html_97e15fd3.png?​302x201}}\\ W celu powrotu do automatycznie wytyczonych tras przewodów wybierz z menu →
 +
 +//**Edycja → Przywróć trasy przewodów**//​ lub kliknij ikon
 +
 +\\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ \\ ====== 3. Edycja elementów ======
 +
 +\\ ===== 3.1. Opis edytora elementów =====
 +
 +{{QuickStart_QET_pl_html_61d9af01.png?​529x398 }}\\ {{QuickStart_QET_pl_html_27d1c79d.gif }}{{QuickStart_QET_pl_html_154f78cd.gif }}{{QuickStart_QET_pl_html_18d8775b.gif }}{{QuickStart_QET_pl_html_2ec4a2.gif }}{{QuickStart_QET_pl_html_8d295f69.gif }}{{QuickStart_QET_pl_html_edfde451.gif }}{{QuickStart_QET_pl_html_13830663.gif }}{{QuickStart_QET_pl_html_69e5522c.gif }}\\ \\ **Pasek menu głównego**-- standardowe menu, które umożliwia dostęp do
 +
 +wszystkich funkcji aplikacji.
 +
 +**Główny pasek narzędzi** -- zawiera ikony podstawowych funkcji związanych
 +
 +z tworzeniem i edycją elementów.
 +
 +**Pasek narzędzi rysunkowych** -- zawiera części graficzne do wstawienia, typu:
 +
 +linia, prostokąt, elipsa, okrąg, wielokąt, łuk, tekst, pole tekstowe i punkt
 +
 +pochwycenia.
 +
 +**Aktywny obszar** -- obszar, który zajmuje edytowany element.
 +
 +**Informacje o częściach** -- wyświetla opcje zaznaczonej części graficznej
 +
 +edytowanego elementu.
 +
 +**Lista części elementu** -- lista wszystkich części graficznych wchodzących w skład
 +
 +elementu.
 +
 +**Historia wykonanych operacji** -- zakładka w której znajduje się lista wszystkich
 +
 +wykonanych i cofniętych operacji.
 +
 +\\ ===== 3.2. Tworzenie nowego elementu =====
 +
 +W panelu Elementy, kliknij prawym przyciskiem myszy na kolekcję użytkownika
 +
 +i wybierz z menu kontekstowego //**→ Nowa kategoria**//​ lub naciśnij ikonę
 +
 +\\ {{QuickStart_QET_pl_html_f0d62e4b.png?​19x19}}\\ następnie wpisz nazwę wewnętrzną i nazwę. Po kliknięciu na przycisk **Wstaw**
 +
 +**wiersz**, można wpisać nazwy w innych językach.
 +
 +\\ {{QuickStart_QET_pl_html_4ee6886d.png?​189x214 }}\\ \\ \\ Naciskamy przycisk OK, w kolekcji użytkownika pojawi się utworzona kategoria.
 +
 +Następnie klikamy prawym przyciskiem myszy na kolekcji użytkownika
 +
 +i wybieramy z menu kontekstowego //**→ Nowy element**// lub klikamy ikonę
 +
 +\\ {{QuickStart_QET_pl_html_14b42e4b.png?​19x19}}\\ W kolejnych oknach asystenta tworzenia nowego elementu, ustalamy: kategorię
 +
 +dla elementu, nazwę pliku, nazwę elementu, rozmiar i aktywny obszar oraz
 +
 +orientację. Następnie w edytorze elementów klikamy ikonę
 +
 +{{QuickStart_QET_pl_html_2dbdc77.png?​19x19}}\\ i rysujemy dwie pionowe linie o długości 10 punktów (w powiększeniu),​ oddalone
 +
 +od siebie o 20 punktów.
 +
 +\\ {{QuickStart_QET_pl_html_bf1ef4d.png?​113x226}}\\ Jeżeli jedna z części elementu jest zaznaczona (kolor czerwony), to w panelu
 +
 +Informacje wyświetlane są opcje tej części. Następnie klikamy ikonę
 +
 +\\ {{QuickStart_QET_pl_html_bd611772.png?​19x19}}\\ i wstawiamy łuk w obszarze edycji. W panelu Informacje ustawiamy w opcjach;
 +
 +średnica poziomo: 5, średnica pionowo: 5, początek kąta: 0 i kąt: 180. Następnie
 +
 +gotowy łuk przeciągamy do pionowej linii jak na rysunku.
 +
 +\\ {{QuickStart_QET_pl_html_73d3d90c.png?​113x167}}{{QuickStart_QET_pl_html_d8ee18e5.gif }}\\ Zaznaczamy łuk kopiujemy trzy razy i przeciągamy w miejsca pomiędzy pionowymi
 +
 +liniami.
 +
 +{{QuickStart_QET_pl_html_edc63b8e.gif }}{{QuickStart_QET_pl_html_256ffa1e.png?​117x152}}{{QuickStart_QET_pl_html_ea9ff33b.gif }}{{QuickStart_QET_pl_html_ffb48114.gif }}\\ Następnie w celu wstawienia punktów pochwycenia klikamy ikonę
 +
 +\\ {{QuickStart_QET_pl_html_f334c58f.png?​19x19}}\\ i wstawiamy klikając w obszarze edycji, w kolejnym kroku ustalamy w panelu
 +
 +Informacje orientację punktów pochwycenia na północ i południe, odpowiednio
 +
 +do miejsca przeznaczenia. Orientacja punktów pochwycenia wskazuje na kierunek
 +
 +przyłączenia przewodów do elementu. Punkty pochwycenia mają kolor czerwony,
 +
 +zaznaczone zmieniają kolor na niebieski.
 +
 +\\ \\ {{QuickStart_QET_pl_html_e778a474.png?​113x169}}{{QuickStart_QET_pl_html_33caa7f1.gif }}{{QuickStart_QET_pl_html_1164de73.gif }}\\ Wybieramy z paska narzędzi graficznych Tekst lub Pole tekstowe
 +
 +\\ {{QuickStart_QET_pl_html_1b3465bb.png?​19x19}}\\ {{QuickStart_QET_pl_html_34647693.png?​19x19}}\\ i wstawiamy w aktywnym obszarze, daje to możliwość oznaczenia elementu
 +
 +po wstawieniu go do schematu. Pole tekstowe różni się od tekstu tym, że może być
 +
 +edytowane po wstawieniu elementu do edytora schematów i może utrzymywać
 +
 +pionową pozycję pomimo obrotu elementu w edytorze schematów. Wielkość tekstu
 +
 +domyślny znak i inne opcje ustalamy w panelu Informacje po zaznaczeniu tekstu
 +
 +lub pola tekstowego.
 +
 +\\ {{QuickStart_QET_pl_html_f3968b0c.png?​113x223}}\\ Ponieważ aktywny obszar wykracza poza rozmiar elementu (pole tekstowe)
 +
 +wybieramy z menu //**→ Edycja → Edytuj rozmiar i aktywny obszar**// lub klikamy
 +
 +ikonę
 +
 +\\ {{QuickStart_QET_pl_html_ebb3473d.png?​19x19}}\\ i zmieniamy wielkość rozmiaru tak aby był większy niż aktywny obszar. Aktywny
 +
 +obszar jest oznaczony kolorem fioletowym.
 +
 +\\ {{QuickStart_QET_pl_html_4a638f4b.png?​265x165 }}\\ \\ \\ Po wybraniu z menu //**→ Edycja → Edytuj nazwę**// lub kliknięciu ikony
 +
 +\\ {{QuickStart_QET_pl_html_f39cb55c.png?​19x19}}\\ można zmienić nazwę elementu lub dodać nazwy w innych językach.
 +
 +Po wybraniu z menu //**→ Edycja → Edytuj orientację**//​ lub kliknięciu ikony
 +
 +\\ {{QuickStart_QET_pl_html_ce82cf1e.png?​19x19}}\\ można ustawić dopuszczalne kierunki obrotu elementu w Edytorze schematów.
 +
 +Dodatkowo można zezwolić lub zabronić na wykonywanie połączeń wewnętrznych.
 +
 +Wybranie z menu **→ Edycja → Informacje autora** lub kliknięcie ikony
 +
 +\\ {{QuickStart_QET_pl_html_144612ee.png?​19x19}}\\ umożliwia wpisanie informacji o autorze, licencji itp. W oknie Edytora schematów
 +
 +odświeżamy kolekcję przez kliknięcie ikony
 +
 +{{QuickStart_QET_pl_html_9975aa38.png?​19x19}}====== 4. Drukowanie schematów ======
 +
 +\\ ===== 4.1. Wybór rodzaju wydruku =====
 +
 +    - W celu wydrukowania schematu wybierz z menu //**→ Plik → Drukuj**// lub kliknij ikonę, ​
 +
 +\\ {{QuickStart_QET_pl_html_336602f1.png?​19x19}}\\ ​    - otworzy się okno w którym wybieramy rodzaj wydruku. Do wyboru są trzy rodzaje wydruku: wydruk na **drukarce fizycznej**,​ wydruk do pliku **PDF** i wydruk do pliku **PostScript**. ​
 +
 +\\ {{QuickStart_QET_pl_html_1c309c13.png?​189x160}}\\ ===== 4.2. Podgląd wydruku =====
 +
 +\\ \\ {{QuickStart_QET_pl_html_b54e6938.png?​529x398 }}\\ {{QuickStart_QET_pl_html_17588727.gif }}{{QuickStart_QET_pl_html_8fb2fb73.gif }}{{QuickStart_QET_pl_html_919fd942.gif }}{{QuickStart_QET_pl_html_aa733a38.gif }}{{QuickStart_QET_pl_html_cf849b80.gif }}\\ \\ **Pasek opcji wydruku i podglądu schematów** -- umożliwia wyświetlanie
 +
 +i ukrywanie opcji wydruku, oraz zmiany w podglądzie schematów.
 +
 +**Lista schematów projektu** -- umożliwia zaznaczanie i odznaczanie schematów,
 +
 +do wydruku.
 +
 +**Opcje renderowania** -- opcje zmieniające wygląd drukowanego schematu.
 +
 +**Opcje wydruku**-- opcje zmieniające dopasowanie wydruku do strony.
 +
 +\\ ====== 5. Eksport schematów ======
 +
 +QElectroTech umożliwia eksport schematów do plików graficznych takich jak:
 +
 +**PNG**%%(*%%.png),​ **JPEG**%%(*%%.jpg),​ **bitmapa**%%(*%%.bmp),​ **SVG**%%(*%%.svg).
 +
 +Wybierz z menu //**→ Plik → Eksport**// a następnie w oknie, które się otworzy wybierz
 +
 +typ pliku do jakiego chcesz eksportować schemat, wskaż katalog docelowy,
 +
 +ustaw pozostałe opcje i naciśnij przycisk **Eksport**.
 +
 +\\ {{QuickStart_QET_pl_html_df59257c.png?​378x184 }}\\ \\ 8.06.2011 //​**QElectroTech {{QuickStart_QET_pl_html_7ee93e7f.png?​34x34 }}0.3 - Szybki start 14/14**//
 +
 +\\
Imprimer/exporter