View Issue Details

IDProjectCategoryView StatusLast Update
0000197QElectroTechElement Editorpublic2020-08-03 17:31
ReporterMarkusGreim Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionGIT/master 
Summary0000197: Arrows in the Element Editor on all lines, not only on the selected one
DescriptionVersion nightly built.
QElectroTech V 0.80-DEV+2b754cffbd79751d3

  1. draw a line element.
  2. select this element
  3. select an arrow as line end.
THEN not only the selected arrow get an arrow, but also
the last drawn or touched line element. Some times more then one
element is affected
Steps To Reproducedraw a line element
draw another line element
select the last line element
select an arrow as line end.
TagsNo tags attached.

Activities

damianCaceres

2020-07-31 15:09

reporter   ~0000434

I can confirm the issue. It's affect more line's widgets, and probably others part primitives.
I'm studing the logic of the style editor. Maybe I will stumble over the solution.

damianCaceres

2020-07-31 21:44

reporter   ~0000435

styleeditor.h
line 49
QList <CustomElementPart *> m_cep_list;

damianCaceres

2020-08-01 11:00

reporter   ~0000436

Last edited: 2020-08-01 11:01

View 2 revisions

Proposal:

1º) Include the statement
	m_cep_list.clear();
on line 482 of the styleeditor.cpp file

2º) Comment the lines 128 and 139 of the lineeditor.cpp
		//style_ -> setPart(nullptr);
		//style_ -> setPart(part);
And so on all editors, because they are launching a redundant execution of the setPart method in styleeditor.

damianCaceres

2020-08-03 16:23

reporter   ~0000437

https://github.com/qelectrotech/qelectrotech-source-mirror/pull/59

Issue History

Date Modified Username Field Change
2020-07-22 18:10 MarkusGreim New Issue
2020-07-31 15:09 damianCaceres Note Added: 0000434
2020-07-31 21:44 damianCaceres Note Added: 0000435
2020-08-01 11:00 damianCaceres Note Added: 0000436
2020-08-01 11:01 damianCaceres Note Edited: 0000436 View Revisions
2020-08-03 16:23 damianCaceres Note Added: 0000437
2020-08-03 17:31 scorpio810 Status new => resolved
2020-08-03 17:31 scorpio810 Resolution open => fixed
2020-08-03 17:31 scorpio810 Product Version SVN/branches/0.x => GIT/master