View Issue Details

IDProjectCategoryView StatusLast Update
0000173QElectroTechDiagram Editorpublic2019-12-10 21:01
Reportermberntsen Assigned Toblack_sun  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformUbuntuOSOS Version
Product VersionSVN/branches/0.x 
Target VersionFixed in Version 
Summary0000173: List of folios overwriting changes
DescriptionHi,

When I insert a list of folios page, and change the title block, folioname/author/date, this information is lost when saving and reopening the file. Might this be because it is regenerated?
I would expect the changed to be kept, and only the index regenerated (or not be regenerated unless requested).
Steps To Reproduce- insert list of folios
- change title block (to custom adaptation of the default, but with the name 'sheet')
- change folioname/author/date
- save document
- close document
- open document
- now the list of folios is named 'list of folios' again and the titleblock is set to the default qet titleblock
Additional InformationQElectroTech V 0.70-dev+svn5685
Compilation: GCC 5.4.0 20160609 - built with Qt 5.5.1 - run with Qt 5.9.5 using 4 thread(s)
TagsNo tags attached.

Activities

scorpio810

2019-07-20 20:01

administrator   ~0000369

Last edited: 2019-07-20 20:06

View 2 revisions

Hi,

yes folios page is generated on the fly and not saved, make your changes in title block folios.
folios page use titleblock new folio setting in your project config.

scorpio810

2019-07-20 20:03

administrator   ~0000370

Btw, you could use search and replace widget for big changes in your project.
vidéo

black_sun

2019-12-10 21:01

developer   ~0000406

Not a bug, this is the normal behavior (even if it's not perfect).

Issue History

Date Modified Username Field Change
2019-07-20 18:28 mberntsen New Issue
2019-07-20 20:01 scorpio810 Note Added: 0000369
2019-07-20 20:03 scorpio810 Note Added: 0000370
2019-07-20 20:06 scorpio810 Note Edited: 0000369 View Revisions
2019-12-10 21:01 black_sun Assigned To => black_sun
2019-12-10 21:01 black_sun Status new => closed
2019-12-10 21:01 black_sun Resolution open => no change required
2019-12-10 21:01 black_sun Note Added: 0000406