View Issue Details

IDProjectCategoryView StatusLast Update
0000128QElectroTechDiagram Editorpublic2017-01-12 00:47
ReporterMorganol Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformQt5.6.2, kf5.29.0, Plasma5.8.5, OS64bit, Linux4.8.15, gcc5.4.0,OS VersionXorg 1.19.0, Mageia6 (dev)
Product VersionSVN/trunk 
Target VersionFixed in Version 
Summary0000128: Crash when quitting r4823
DescriptionWhen i closed the QET window by the [x] window frame button, i got this crash caught by running it in debug from qtcreator. Screenshot attached.
I believe - but am not 100% sure - i did not edit anything before last save.

I believe it is r4823 as svn up did not download anything, but said anyway it is r4824 as it report latest version in another branch
https://qelectrotech.org/forum/viewtopic.php?pid=6053#p6053
TagsNo tags attached.

Activities

Morganol

2016-12-28 09:07

reporter  

Crash quitting r4823.png (385,434 bytes)

scorpio810

2017-01-09 19:32

administrator   ~0000228

Last edited: 2017-01-09 19:36

View 3 revisions

Launch QET, new project, close :

qelectrotech[17167]: segfault at 7fcfc808ece0 ip 00007fcfe220cc63 sp 00007ffed72d64e0 error 4 in libQt5Gui.so.5.7.1[7fcfe208d000+51d000]


https://download.tuxfamily.org/qet/forum_img/bug_2017-1.png">


screen



Backport upstream change to fix crashes on exit in some applications

+Description: make the bearer QFactoryLoader a member variable, not a static
+ Because it was a function-level static, the QFactoryLoader was getting
+ destroyed out-of-sync with the bearer thread stopping. Under normal
+ conditions, the thread stopped first (~QApplication / ~QCoreApplication
+ via qAddPostRoutine), and the static got destroyed when the process
+ exited. However, if QApplication leaked or if the destruction order is
+ wonky (as seen in PyQt5), the thread could still be running when the
+ plugins were already unloaded.
+ .
+ With the loader a member variable, it gets destroyed when the thread
+ stops.
+Origin: upstream, https://code.qt.io/cgit/qt/qtbase.git/commit/?id=7c402ad3d15ff5e7
QT bug 1?

me

scorpio810

2017-01-09 19:34

administrator  

bug_2017-1.png (159,208 bytes)
bug_2017-1.png (159,208 bytes)

scorpio810

2017-01-12 00:47

administrator   ~0000230

Qt 5.7.1+dfsg-3

Dmitry Shachnev (8):
      Start a new changelog entry.
      Backport upstream change to fix accessibility-related crashes.
      Backport upstream fix to make QGtk3Dialog not crash on Wayland.
      Backport upstream change to fix crashes on exit in some applications.
      Close bug #850746 in the changelog.
      Revert "Backport upstream change to fix crashes on exit in some applications."
      Backport change to stop unloading plugins in QPluginLoader and QFactoryLoader.
      Release to unstable.

Issue History

Date Modified Username Field Change
2016-12-28 09:07 Morganol New Issue
2016-12-28 09:07 Morganol File Added: Crash quitting r4823.png
2017-01-09 19:32 scorpio810 Note Added: 0000228
2017-01-09 19:34 scorpio810 Note Edited: 0000228 View Revisions
2017-01-09 19:34 scorpio810 File Added: bug_2017-1.png
2017-01-09 19:36 scorpio810 Note Edited: 0000228 View Revisions
2017-01-12 00:47 scorpio810 Status new => resolved
2017-01-12 00:47 scorpio810 Resolution open => fixed
2017-01-12 00:47 scorpio810 Note Added: 0000230