2019-09-19 14:33 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000115QElectroTechDiagram Editorpublic2016-11-20 18:45
ReporterMorganol 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformQt5.6.1, kf5.27.0, Plasma5.8.2, OS64 bit, Linux 4.8.5, gcc 5.4.0, OS VersionMageia 6 (devel)
Product VersionSVN/trunk 
Target VersionFixed in VersionSVN/trunk 
Summary0000115: Make master&slave elements xref clickable ( like folio referencing links are )
DescriptionRef: https://qelectrotech.org/forum/viewtopic.php?pid=5839#p5839
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0000204

Morganol (reporter)

I see the first step :)
Now at master clicking a contact xref, takes you to that contact.
(Works for view as contacts, not as cross)

4784 3t 29m blacksun /trunk/ Cross ref item : Double click in a contact of the Xref, go to the real contact. (only available for Xref draw as contacts)

~0000205

Morganol (reporter)

Reopening...
"In the works" i wrote in forum, meaning it is being worked upon but not yet finished.

Current state is that double-clicking an xref at a master, take you to that slave, nice :)

I reopen because the xref at the slaves are not yet live. (should take you to its master)

-----
Strange here in Mantis: I pressed button "Reopen" but got this form with button "Request feedback" that i now press.

~0000206

Morganol (reporter)

Ah... OKOK it is implemented this way: on slave double click LABEL (not xref)

I learned it by mistake at slave double click the *label" and that brought me to master ;)

SO:

  • at master double click the xref (or in view contacts mode the contact also works)

  • at slave double click the *LABEL*

    I see the logic: the label is the name of the MASTER device.
    It would be more intuitive though if it would react to double cliking on the xref (also)
  • +Notes

    -Issue History
    Date Modified Username Field Change
    2016-10-30 20:13 Morganol New Issue
    2016-11-16 23:41 Morganol Note Added: 0000204
    2016-11-17 22:00 scorpio810 Status new => resolved
    2016-11-17 22:00 scorpio810 Resolution open => fixed
    2016-11-17 22:00 scorpio810 Fixed in Version => SVN/trunk
    2016-11-17 23:52 Morganol Status resolved => feedback
    2016-11-17 23:52 Morganol Resolution fixed => reopened
    2016-11-17 23:52 Morganol Note Added: 0000205
    2016-11-18 01:24 Morganol Note Added: 0000206
    2016-11-18 01:24 Morganol Status feedback => new
    2016-11-20 18:45 scorpio810 Status new => resolved
    2016-11-20 18:45 scorpio810 Resolution reopened => fixed
    +Issue History