1 (edited by Laurent07 2014-11-05 22:16:08)

Topic: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Bonjour
Quand j'ouvre avec qelectrotech-0.4-devel+svn3450-x86-win32-readytouse des fichiers crée avec une ancienne version les références des disjoncteurs ont disparues et sont remplacées par un tiret.
Laurent

Post's attachments

Image.jpg, 806.61 kb, 1100 x 1500
Image.jpg 806.61 kb, 376 downloads since 2014-11-05 

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Bonjour,

En effet, sur les révisions 3421 à 3125 les champs textes en "_" ont été mis en champ texte "_" +   label sur ~85% de la collection, ces symboles auraient déjà du avoir ce champ mis en label.

Ça explique pourquoi quelques valeurs ont disparues.. et ça peut être gênant sur des schémas fait sur d'anciennes versions, je le conçois.

Merci Laurent du retour et désolé c'étais pas prévu.

Nous allons réfléchir à une solution.
Une solution serait de faire machine arrière, soit un revert des versions concernées .... du trunk, au risque d’être pénalisant pour vous et pour les futurs avancements, et d'avoir des éléments avec un champ label et d'autres pas.

Le but de ce champ label étant justement de n'avoir qu'a renseigner une seule fois l'information dans le widget en même temps que le commentaire etc, il est ensuite automatiquement écrit à coté du symbole et vient remplacer l'underscore (_).
De ce fait pas d'erreurs entre les valeurs sur le dessin et celles que la nomenclature donnera.

Laurent

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Apres recherche le problème ne vient pas des labels, attendez avant de reprendre vos schémas.

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Le bug est repéré.

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

La révision 3459 règle ce problème, mais les commentaires en bas de pages ne sont plus affichés pour le moment.
Les builds sont en cours d'upload.

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Pour un très bon logiciel open source beaucoup sont prêts à être patients.

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Merci Laurent et surtout un grand merci pour le retour, a deux c'est vraiment difficile de tout faire, et sur notre temps libre..., et surtout de tout tester dans tous les sens. nomicons/smile
Voila les builds sont dans les dépôts.

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Bonjours le problème doit être réglé avec la rev3460 (pouvez vous le confirmé).
Attention, vous retrouverez les anciens textes seulement si vous n'avez pas sauvegardé votre schéma avec la version bugué.

Merci de vos retour.

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Pas du tout, nomicons/tongue
Certains champs de texte sur plusieurs lignes et ou déplacés ne sont plus lu et sont remplacé par un underscore.
Dans le cas ou ce champ a été supprimé, il est de nouveau rajouté l'underscore par défaut.
Je garde mon patch de la 3459 nomicons/smile

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

Bravo pour le SAV. Problème réglé en moins de 24h. Beaucoup mieux que certains gros éditeurs.
Mes fichiers crée avec la version 3429 sont correctement lus avec la version 3459.
Laurent

Re: Problème avec version qelectrotech-0.4-devel+svn3450-x86-win32-readyto

La révision 3464 règle définitivement le problème et les commentaires en bas de pages sont de retours.
Les builds sont dans les dépôts.