Diferencias

Muestra las diferencias entre dos versiones de la página.

Enlace a la vista de comparación

Ambos lados, revisión anterior Revisión previa
es:doc:install_debian [20/11/2014 13:01]
127.0.0.1 editor externo
es:doc:install_debian [30/09/2018 23:08] (actual)
scorpio810 [Paso 4 instalación]
Línea 1: Línea 1:
 +====== Instalación de QElectrotech bajo Debian ======
 +{{:​doc:​logo_debian.png|}} {{:​doc:​logo_ubuntu.png|}} Este documento describe el procedimiento que debe seguirse para instalar la última versión estable (0.2) de QElectroTech bajo Debian GNU/Linux (y sus derivadas).
 +
 +===== Deposito oficial Debian =====
 +
 +**QElectroTech 0.2 (svn716)** está disponible recientemente bajo** Debian** (main), ramas sid (unstable) y squeeze (testing) \\ y es paquete de medidas para las siguientes arquitecturas Debian:\\ **i386, amd64, alpha, hppa, hurd-i386, ia64, kfreebsd-amd64,​ kfreebsd-i386,​ mips ,mipsel, powerpc, s390 , armel y sparc.** ​
 +
 +[[http://​packages.debian.org/​sid/​qelectrotech]]
 +
 +
 +[[http://​packages.debian.org/​sid/​qelectrotech]]
 +
 +===== Instalación =====
 +<code bash>​apt-get install qelectrotech qelectrotech-data qelectrotech-examples</​code>​
 +
 +Aquí, QElectroTech debería en adelante ser instalado. Puede lanzarlo mediante el pedido “qelectrotech”. si su medio ambiente de oficina respeta las normas FreeDesktop.org,​ QET debería también aparecer en sus menus y los ficheros .qet y .elmt deberían abrirse por defecto en QElectroTech.
 +
 +===== Instalación de las últimas versiones (snapshot svn) =====
 +:!: Nota: la mayoría de las manipulaciones presentadas abajo deben efectuarse en un terminal. ​
 +
 +==== Paso 1: Determinar qué versión de Qt está disponible sobre sus depósitos ====
 +<​code>​laurent@laptop:​~$ apt-cache policy libqt4-core
 +libqt4-core:​
 +  Installé : 4.5.1-2
 +  Candidat : 4.5.1-2
 + Table de version :
 + *** 4.5.1-2 0
 +        997 http://​ftp.fr.debian.org unstable/​main Packages
 +        100 /​var/​lib/​dpkg/​status
 +</​code>​
 +Aquí, el ordenador portátil de laurent dispone de la biblioteca Qt en versión 4.5.1. ​
 +
 +==== Paso 2: Deducir el depósito que debe utilizarse ====
 +  * Para Qt < 4.4.0: Ah, no importa, las últimas versiones de QElectroTech (a partir de 0.11 en realidad) requieren de Qt ≥ 4.4.0 
 +
 +==== Debian lenny , Ubuntu (Intrepid, Jaunty, Karmic) ====
 +  * Para Qt ≥ 4.4.0 y < 4.5.3 : <​code>​deb http://​scorpio810.blogdns.net/​qelectrotech/​ lenny main</​code>​
 +
 +==== Debian Squeeze , Sid ====
 +  * Para Qt ≥ 4.5.3 : <​code>​deb http://​scorpio810.blogdns.net/​qelectrotech/​ unstable main</​code>​
 +
 +==== Paso 3: añadir el depósito a su sources.list ====
 +El más simple para obtener el paquete es añadir en su sources.list la línea determinada a la etapa anterior. Para ello, editen el fichero ''/​etc/​apt/​sources.list'':​ <​code>#​ Jeunot sous Ubuntu
 +sudo nano /​etc/​apt/​sources.list
 +# Vieux Debianeux
 +vim /​etc/​apt/​sources.list
 +</​code>​
 +
 +Conviene a continuación poner al día su cache: <​code>​apt-get update</​code>​
 +
 +==== Paso 4 instalación ====
 +<​code>​apt-get install qelectrotech qelectrotech-data qelectrotech-examples qet-tb-generator</​code>​
 +y si tiene necesidad de los símbolos hidráulicos
 +
 +<​code>​apt-get install qelectrotech-data-hydraulic</​code> ​
  
Imprimir/exportar
Idiomas