View Issue Details

IDProjectCategoryView StatusLast Update
0000221QElectroTechwebsitepublic2021-02-15 00:51
Reporterplc-user Assigned Toblack_sun  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSVN/trunk 
Fixed in VersionSVN/trunk 
Summary0000221: Editing ARC-center affects ARC-diameter and vice versa
DescriptionWhen manually editing the position of the center of an ARC the diameter for the same direction changes, too.
Example:
given ARC with
center x=0, y=0 and
diameter horizontal=20 vertical=20

when changing horizontal diameter to 19 it moves x-center to -0.5

then changing x-center to 0 changes horizontal diameter to 18.5 and x-center to -0.25

-> there seems to be no way to edit position and diameter of arc manually!
-> very strange behavior!

we had similar bugs before with circles/ellipses and lines and rects...
(cannot remember the bug-report-number)
Steps To Reproduceas described...
Additional InformationQET-Version:
QElectroTech V 0.80-rc+74342cb00c957a06d79751d3
Compilation : GCC 10.2.1 20201207
Built with Qt 5.15.2 - Date : Dec 22 2020 : 14:57:23
(running on Debian unstable)

but bug exists for several versions!
TagsNo tags attached.

Activities

black_sun

2021-01-28 19:29

developer   ~0000476

Fixed in git aa66eabe7c9e690e76d6046fc46d2b0bf95d8caf

Issue History

Date Modified Username Field Change
2021-01-02 22:02 plc-user New Issue
2021-01-28 19:29 black_sun Assigned To => black_sun
2021-01-28 19:29 black_sun Status new => resolved
2021-01-28 19:29 black_sun Resolution open => fixed
2021-01-28 19:29 black_sun Fixed in Version => GIT/master
2021-01-28 19:29 black_sun Note Added: 0000476
2021-02-15 00:44 user245 Product Version => 0.8
2021-02-15 00:45 user245 Fixed in Version GIT/master => SVN/trunk
2021-02-15 00:47 user245 Product Version 0.8 => SVN/trunk
2021-02-15 00:51 user245 Category Element Editor => website